When reloaded page contains CHECKED option - the check is not appearing

VERIFIED DUPLICATE of bug 46845

Status

()

Core
HTML: Parser
VERIFIED DUPLICATE of bug 46845
13 years ago
13 years ago

People

(Reporter: Seth Rubin, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

When a frame is reloaded, the check isn't displaying in a <select> list
<option>, even when the CHECKED directive is now present.  I'm authoring a
web-page and viewing it with Firefox as I work on it.  

I had a bunch of <option>'s within a <select>, but none was CHECKED.  I viewed
the page in Firefox, saw that none was CHECKED, so I changed my code to add
CHECKED to the first <option> .  I then reloaded the frame in question, and the
first option displayed still appeared unchecked, even though when I did a
view-source for that frame, the CHECKED was clearly there.  When I exited the
page and re-created it, the check appeared properly.


Reproducible: Always
Steps to Reproduce:
1. View a page containing frames in FireFox.  One frame should contain a
<select> radio-button list with no <option>'s being checked
2. Upload new version of page with one of the <option>'s now CHECKED
3. Right-click the frame and select "This Frame - Reload Frame"

Actual Results:  
The <option> in question is still not checked.

Expected Results:  
The <option> should have appeared checked.

Comment 1

13 years ago
An OPTION can't be CHECKED (but can be SELECTED) and a SELECT can't have radio 
buttons?! 
(Reporter)

Comment 2

13 years ago
My apologies the description - I was confused because I was working on something
else at the same time.  It was an <input type="radio"> tag, not <option> and
<select>.  I've also been noticing other anomalies when I reload a frame - some
label text not refreshing either.  The frame being reloaded is dynamic content -
a PHP page. [Seth Rubin]
Not a parser issue.  You want to reload with shift-reload, not just reload, if
you need to ensure form controls get reset.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.