While modal dialog/window up for a tab, cannot change tabs

RESOLVED DUPLICATE of bug 123913

Status

()

enhancement
RESOLVED DUPLICATE of bug 123913
15 years ago
15 years ago

People

(Reporter: antin, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

One of the webpages I was reading popped up a modal dialog box and I was unable
to change to another tab. I wouldn't call this a bug as such, but it would be
very nice if you could do so. In this case the modal dialog was prompting me for
a password, and the password was displayed on the other tab (so I needed to
change tabs to see the password).

The modal dialog was actually presented by Adobe Acrobat Reader (version 6) as I
was viewing a PDF file (from within the browser). I am not sure if a modal
dialog presented by a web page has the same effect.

Reproducible: Always
Steps to Reproduce:
1. Open multiple tabs.
2. Have one tab display a modal dialog box.
3. Try to change tabs.

Actual Results:  
Could not change tabs until I had closed the modal dialog box.

Expected Results:  
Allowed me to change to any tab, but not continue working on the tab with the
modal dialog box until it was closed.

A good example of this problem can be found by visiting this site:

http://wpc.puzzles.com/gt-IV/index.htm

If click and bring up the 'password' link on a seperate tab, and on the first
tab click to view the pdf file you should see what I mean.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 123913 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.