All users were logged out of Bugzilla on October 13th, 2018

cannot highlight parts of url while all of url is highlighted

VERIFIED DUPLICATE of bug 87410

Status

()

VERIFIED DUPLICATE of bug 87410
15 years ago
14 years ago

People

(Reporter: hajj_3, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: firefox 0.9

if a url is highlighted in the address bar, if you want to select 
say "mircrosoft" from http://www.microsoft.com it wont work, you get the no 
entry cursor. you have to unselect the whole address, then select the part you 
want. so you cant just select "microsoft" and type "mozilla" in its place to 
go to mozilla.com. this works in internet explorer, but not in firefox 0.9.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
if a url is highlighted in the address bar, if you want to select 
say "mircrosoft" from http://www.microsoft.com it wont work, you get the no 
entry cursor. you have to unselect the whole address, then select the part you 
want. so you cant just select "microsoft" and type "mozilla" in its place to 
go to mozilla.com. this works in internet explorer, but not in firefox 0.9.

Expected Results:  
to select the text you want to highlight instead of giving you a no entry 
cursor.

Comment 1

15 years ago
This is intentional. Clicking and moving the mouse on a highlighted URL
initiates dragging of the URL text. While this is different from IE it allows
the dragging and dropping of URLs into text boxes and other programs like Word.

Comment 2

14 years ago
I used to find this behaviour absolutely infuriating until I understood it a bit
better. If you don't click into the address bar, but instead just immediately
drag over the text that you wish to select, then it works as expected.

So it sort of gives you the best of both worlds (i.e. immediate full selection
for line deleting / drag and drop, as well as immediate partial URL selection
highlighting). In that respect it is BETTER than IE (because you can not
directly drag over a word in IE to select it, unless the whole line is already
selected).

I still have not got completely used to way Firefox works, and so I find myself
inadvertantly dragging address bar text all the time (when in fact I had mean't
to highlight part of it).

However, I do find it annoying when when I want to insert text into a URL in
Firefox. In Windows, to place a cursor in a text box you simply click once and
start typing (admittedly IE's address bar does not follow this convention) but
in Firefox's address bar I regularly have to triple-click because the second
click often selects a word, rather than placing the cursor.

I'm not sure if I will ever get used to that particular behaviour, because it
seems far more intuitive (and consistent with other apps) to double or triple
click when you want to highlight something (e.g. a word, whole line or
paragraph), while single clicking is normally used to place the cursor. An
example is highlighting a plain text word on a web page viewed within Firefox.
When you single click on the word it does not get selected (that only happens
when you double click on it).

Ctrl + A can be used to easily select the entire address bar URL, but there is
no shortcut to obviate the need for double / triple clicking when you wish to
place the cursor at a specified point within the URL.

See bug 114862. It was resolved wontfix. You can use the
browser.urlbar.clickSelectsAll pref to change this behaviour, so if you don't
like the current behaviour just change the pref in about:config.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
87410 is much more on point. 

Besides, /even if/ this is a dupe of a wontfix bug, dupe it to the wontfix bug.

*** This bug has been marked as a duplicate of 87410 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.