Addresses that contain username/password @host should be color coded

RESOLVED DUPLICATE of bug 122445

Status

--
enhancement
RESOLVED DUPLICATE of bug 122445
15 years ago
14 years ago

People

(Reporter: stein, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040313
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040313

When an address contains a username:password@host,
the username and passwords should be in a different
color to make it stand out that they are not
the host.  This should help against spoofing attacks.
This would be a handy option to have and should
probably be on by default.
This is similar to other syntax highlighting schemes.

Reproducible: Always
Steps to Reproduce:
1. Put in address with user:pass
2.
3.

Actual Results:  
URL is one color

Expected Results:  
Part before @ should be a different
color to make it stand out.

Comment 1

15 years ago
see the discussion in bug 122445

*** This bug has been marked as a duplicate of 122445 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 2

14 years ago
See also bug 184074.
You need to log in before you can comment on or make changes to this bug.