JavaScript strict warnings and error

VERIFIED DUPLICATE of bug 249012

Status

()

Toolkit
Add-ons Manager
--
minor
VERIFIED DUPLICATE of bug 249012
14 years ago
10 years ago

People

(Reporter: Ng Ming Hong, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When starting Firefox 0.9.1, 29 JavaScript strict warnings are found in
"[FirefoxDir]/components/nsExtensionManager.js" and one error is found in
"chrome://global/content/alerts/alert.js"

The warnings are all "redeclaration of variable".
The error is an uncaught exception (as follow):
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002
(NS_NOINTERFACE)"  location: "JS frame ::
chrome://global/content/alerts/alert.js :: prefillAlertInfo :: line 69"  data: no]

Reproducible: Always
Steps to Reproduce:
1. Open Firefox 0.9.1
2. Open JavaScript Console
Actual Results:  
29 strict warnings and 1 error are found in Firefox's js files

Expected Results:  
No warning and error

"javascript.options.strict" need to be set as "true"
This can be changed using "about:config".

Comment 1

14 years ago
Works for me. I only see redeclaration errors, which I guess are perfectly valid
since the variable's passed out of scope. Are you reproducing this on a new profile?
(Reporter)

Comment 2

14 years ago
hao2lian, you are right.
Just did a fresh install of Firefox 0.9.1 (profile removed) on Windows 2000 SP
4. Only strict warnings are found.

The error is most like caused by the Extensions that I installed?
FYI, the extensions are:
- All-in-one Gestures 0.11.1
- Web Developer 0.8
- Launchy 3.0.0

Hope it helps...
(Reporter)

Comment 3

14 years ago
Just installed all the 3 extensions mentioned before on that newly installed
Firefox. Still no error found.

Maybe there is caused by the old 0.9 (not 0.9.1) profile.

Comment 4

14 years ago
--> Resolve as Worksforme

Comment 5

14 years ago
The strict warnings in the EM are covered in Bug 249012, since you can no longer
reproduce the error I'll just mark this as a duplicate.

*** This bug has been marked as a duplicate of 249012 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.