Last Comment Bug 249280 - mozcc cannot access RDF creative commons licence in SVG files loaded by the adobe asv3.1 plugin
: mozcc cannot access RDF creative commons licence in SVG files loaded by the a...
Status: RESOLVED WONTFIX
[adobe svg plugin]
:
Product: External Software Affecting Firefox
Classification: Components
Component: Other (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.peepo.co.uk/launch/index.svg
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-30 12:30 PDT by jonathan chetwynd
Modified: 2010-06-29 02:08 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description jonathan chetwynd 2004-06-30 12:30:04 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1

Mozcc is an excellent extension which provides creative commons licence
information when it is present as RDF. http://www.yergler.net/projects/mozcc/

However this only works for HTML or Mozilla native SVG.

There is a problem with Mozilla architecture and adobe asv3.1 plugin
architecture that is preventing   mozcc accessing the RDF creative commons licence.

This would appear rather strange, as this is all text, and presumably available
to mozilla irrespective of the adobe plugin, eg <view source> displays correctly.

I realise that this is a tricky issue, and believe it needs urgent attention.
Mozcc represents an extremely good use of RDF.
Furthermore SVG, CC, and Mozilla are all dedicated to open source in their
different ways.

firefox0.9.1 rocks

please get this done!

Reproducible: Always
Steps to Reproduce:
1.install adobe asv 3.1
2.install mozcc
3.visit http://www.peepo.co.uk/launch/index.svg

Actual Results:  
mozcc claims no RDF creative commons licence information is available

Expected Results:  
graphical icon indicating Public Domain
further and full information when clicking on the CC icon
Comment 1 Peter Sorotokin 2004-06-30 14:17:34 PDT
Does it happen if some other plug-in is responsible for rendering? I am not 
sure how mozcc works, but I think that Mozilla implicitly creates an 
HTML "thunk" to pull-in plug-in data which looks like this:

<html>
<body>
<object data="..."/>
</body>
</html>

Maybe mozcc mistakenly tries to get licence out of that thing. 
Comment 2 Nathan R. Yergler 2004-07-01 05:08:47 PDT
Yes, that is what mozCC does.  For HTML documents it uses
document.documentElement.innerHTML to get the document contents and then parse
them for in-comment RDF, etc.  It seems that the Adobe SVG plugin doesn't
actually expose the DOM tree in a similar fashion.  Of course, I'm open to
suggestions on other (better) ways to extract the document source, or ways to
access the Adobe SVG DOM that I haven't tried yet.
Comment 3 Peter Sorotokin 2004-07-01 10:19:40 PDT
You won't be able to access Adobe SVG DOM since it not (and could not) be 
exposed to Mozilla. This problem might be fixed in the future versions of 
Mozilla and SVG plugin - but that's long term. Meanwhile you could detect an 
HTML stub, load the source of the object and parse it using regular Mozilla 
XML parser. This would work with all XML formats and all plug-ins.
Comment 4 Gervase Markham [:gerv] 2005-09-27 02:06:07 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 5 jonathan chetwynd 2005-10-01 13:39:29 PDT
I can't help that no one is working on this bug
Comment 6 aravindm 2010-04-02 02:55:06 PDT
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.2)
Gecko/20100316 Firefox/3.6.2
Reporter, Please try if you can reproduce with the latest
nightly build ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Comment 7 Robert Longson 2010-06-13 13:07:39 PDT
The adobe SVG 3.1 plug in is dead. It it no longer supported by Adobe.
Comment 8 jonathan chetwynd 2010-06-13 13:30:21 PDT
Robert,

please leave my bugs alone, this has nothing to do with adobe
Comment 9 Robert Longson 2010-06-13 14:06:11 PDT
In comment 0 you wrote

> There is a problem with Mozilla architecture and adobe asv3.1 plugin
> architecture that is preventing   mozcc accessing the RDF creative commons
> licence.

So why is it now not about Adobe?
Comment 10 timeless 2010-06-29 02:08:36 PDT
this would require some effort by the plugin vendor, and as the plugin is defunct, this bug is effectively wontfix.

Note You need to log in before you can comment on or make changes to this bug.