The default bug view has changed. See this FAQ.

no browser response when following file:// hrefs in a page

RESOLVED DUPLICATE of bug 84128

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 84128
13 years ago
13 years ago

People

(Reporter: chris weekly, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Firefox/0.9

I can manually type file:// uris in the location bar.
I can bookmark them once I've done this.
But I cannot click on a link in an intranet page which has as its href attribute
href="file:///%5C%5Cterriers.corp.upromise.com%5Cdocs%5Cengineering%5Cbuilds%5Cbranches.htm"

I'm trying to convince managers at my company to switch to firefox asap,
but this is holding them up, as the intranet html developers often link to
important documents using the file: protocol. 
I know the path is ok because bookmarks and pasting into location bar works fine. 


Reproducible: Always
Steps to Reproduce:
1. create a link with a file:// uri in an html pg
2. open ff0.9
3. try to click the link. (nothing happens)

Actual Results:  
nothing

Expected Results:  
fetch the requested resource

nothing special.
(Reporter)

Comment 1

13 years ago
(In reply to comment #0)
P.S. Note I generally use 0.8
this is reproducible in both 0.8 and 0.9.
other people have reported this same problem to me.
thanks.

Comment 2

13 years ago
This is deliberate.  See bug 122022 and bug 84128.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
Also see http://www.mozilla.org/releases/mozilla1.7/known-issues.html#psm for
how to disable this security function, if you're really inclined to do that.
You need to log in before you can comment on or make changes to this bug.