Context Menu menupopup (sub Menu) items don't work after sequence of mouse clicks

RESOLVED WORKSFORME

Status

()

Core
XUL
--
critical
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Jason Adams, Assigned: Blake Ross)

Tracking

({crash})

1.7 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

A reproducable sequence of mouseclicks causes menupopup (sub menu) items in the
context menu of the browser to stop functioning. An extension is required to
reproduce this problem as there are no Context Menu menupopup items in the
default istallation of Firefox that i could find. A Simple extension with no
code, just the xul overlay for the context menu is available at
http://www.yellowgorilla.net/files/submenutest.php. This can be used to test
this bug.

Reproducible: Always
Steps to Reproduce:
1. Install the extension from http://www.yellowgorilla.net/files/submenutest.php
2. Click anywhere on the browser window of firefox with the right mouse button
3. Select the item "Sub Menu Test" from the context menu so it displays the sub menu
4. While the sub menu is still open, Click on the item in the main part of the
context menu that says "Click me while sub menu is open"
5. Repeat steps 2 & 3. The menupopup submenu does not appear the second time

Actual Results:  
The menupopup submenu does not appear the second time as expected. There is no
code in this extension that controls the appearance of the context menu so
apperance of menuitems is controlled by the firefox code.

Expected Results:  
the menupopop submenu should be displayed for the user to select a menu item from.  

This problem does not appear to be a problem with the items in the main firefox
menu. I have only observed it on the context menu of the browser. This bug was
found whilst testing an exension I am developing
http://www.yellowgorilla.net/imagezoom/imagezoom.php so to test, I wrote a
simple extension to add the required item to the context menu and nothing else,
then tested it on a fresh install of firefox with no other extensions installed.
(Reporter)

Comment 1

14 years ago
Created attachment 152287 [details]
Firefox 0.9 Extension needed to test this bug
(Reporter)

Comment 2

14 years ago
I am also able to reproduce this bug on:
Mozilla Mozilla 1.7 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040616
Thunderbird version 0.7.1 (20040626)
(Reporter)

Updated

14 years ago
Component: Menus → Browser-General
Product: Firefox → Browser
Version: unspecified → 1.7 Branch

Comment 3

14 years ago
I can reproduce it too.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040817
Firefox/0.9.1+

Comment 4

14 years ago
I can reproduce it too (Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10.1), actually it is a problem with any submenu in the
context menu - I got it with Launchy and also with Web Developper.
Unfortunately there is no default item in the context menu that has a submenu
(maybe it is a 'bad UI' but this would be another issue :-) and thus it will
only affect extension.

Just to be clear if you try to repro this bug you need to be quick!
1. Right click in a page to make the Context Menu appear
2. bring the mouse over a Context Menu item which has a submenu (appearing as an
arrow) like the Launchy or the Web Developper extensions and let the sub menu pop up
3. *quickly* move the mouse to another item in the main Context Menu and click
it (for example, if you use Launchy for the test, just click the Select All item
just above the Launchy item)
4. Now that item in the Context Menu won't have any more sub-menu, in fact
making the extension impossible to use

Note that the second time I was trying to repro the bug I even got a crash : 
TB1144558H
but unfortunately I could not find again the precise procedure that lead to the
crash later - maybe not directly related.

A few more comments:
- as in my context menu I have Launchy and Developper Tools I could see that the
submenu is only disabled for the item for which you did the procedure above.
That is, after the submenu of Launchy disappeared I still had the Developper
Tools submenu, and I could then make it disappear by using the procedure above
on it.
- although it seems that it is a UI issue (maybe linked with the timer used to
leave the popup menu open when the mouse leaves an item?) it affects both
Mozilla AND Firefox thus it must be in a shared code part of the UI - or in
Gecko (?).
- relaunching the browser restore the popup submenu
- the menu under Tools is not affected by the bug
- enabling/disabling the extension in the same session does not restore the
popup submenu
- there is no message in the JavaScript console

As I got a crash, reporter you may want to add that keyword 'crash') and bump
the priority to critical which is the normal procedure for a crash bug - but as
I said I could not repro the crash after...

For sure the component should be changed to "XPToolkit/Widget:menus" I think
because browser-general don't get much attention I'm afraid.
(Reporter)

Comment 5

14 years ago
I too have experienced the crashing (numerous times) with this bug but am not
sure the exact steps needed to reproduce the crash.
Severity: normal → critical
Component: Browser-General → XP Toolkit/Widgets: Menus
Keywords: crash

Comment 6

14 years ago
Confirmed the bug described in initial report using Web Developer extension.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1

Not 100% sure about the component.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Severity: critical → normal

Comment 7

14 years ago
I cannot reproduce this bug with a current trunk Firefox build. Could you try to
reproduce it with a build from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ?

btw, Firefox does have a submenu in the context menu by default -- the Frame
menu, only visible on pages with frames. I used it and Flashgot's submenu when
trying to reproduce.

raising severity to critical because of crash keyword.
Severity: normal → critical
(Reporter)

Comment 8

13 years ago
This bug seems to have gone away in the latest 1.8 gecko version. I do not experience this problem anymore with firefox 1.5b2

Comment 9

13 years ago
Neither me (comment 7), nor original reporter (comment 8) can reproduce the bug using Firefox 1.5 builds. Resolving the bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
QA Contact: bugzilla → xptoolkit.menus

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.