All users were logged out of Bugzilla on October 13th, 2018

Can't create two POP accounts on two different ports on the same server (same username on each account)

RESOLVED DUPLICATE of bug 41929

Status

RESOLVED DUPLICATE of bug 41929
15 years ago
14 years ago

People

(Reporter: osteinert, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

I use the Spambayes sb_server.pl POP proxy to filter my mail. I have multiple
POP accounts set up in Spambayes that operate on different ports (i.e. 1101,
1102, etc.) on the local machine (localhost). When I try to create more than one
account in Mozilla Mail that uses "localhost" as the POP server I receive an
error message that says "An account with that username and server name already
exists. Please enter a different user name and/or server name."

It just so happens that I have two different accounts from different ISPs that
have the same user name. So I end up with Spambayes proxying the two accounts,
and I need to create two accounts in Mozilla Mail to access them. One account is
hooked up to localhost:1101, username: example_name, and the other needs to be
hooked up to localhost:1102, username: example_name. Mozilla doesn't like this
(and I can see why), but it prevents legitimate uses like the one described
above. I worked around the problem by using 127.0.0.1 for the second account's
server name, but this won't work a third time (just a guess, I haven't actually
tried).

Reproducible: Always
Steps to Reproduce:
1. Set up POP proxy on localhost (i.e. spambayes)
2. Configure proxy for two different accounts with the same username for each,
for two different POP servers, on two different local ports (1101, 1102 for example)
3. Create Mozilla Mail POP account for first server, pointed to localhost:1101
4. Create Mozilla Mail POP account for second server, pointed to localhost:1102
with the same username as the first account. It will fail with an error message
as described in "Details".
Actual Results:  
Error message appeared. "An account with that user name and server name already
exists. Please enter a different user name and/or server name."

Expected Results:  
I should be allowed to create two POP accounts with the same username and server
name as long as they are on different ports.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 41929 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.