Firefox shouldn't unregister Mozilla as default application after uninstallation

RESOLVED WORKSFORME

Status

()

Firefox
Installer
--
major
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Jure Repinc (JLP), Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Reproducable: always

Steps to reproduce:
1. Make sure Mozilla or Firefox are not installed
2. Install Mozilla and make it the default (this registers it with certain file
types and it is now the default browser/mail)
3. Install Firefox and DON'T make it default
4. Unistall Firefox

Results:
Mozilla is no longer associated with files and it is no longer the default
browser. The Internet link is also reverted back to Internet Explorer on Windows
Start Manu.

Expected results:
Mozilla should remain associated with files and it should remain the default
browser. Internet icon in Start Menu should still be pointing to Mozilla and
Mozilla Mail.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 1

14 years ago
could you please try with a newer version from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9 ? There was a
recent (related) fix.

Comment 2

14 years ago
Same thing happens to Netscape 7.1/7.2. Last time I uninstalled FF (FF 0.9.3),
it also made Netscape 7.2 non-default mail app. Also, FF uninstaller shuts down
Netscape and Netscape Quick Lunch.

LXR shows 26 instances of netscp.exe in the Aviary branch.
Confirmed with 1.0PR uninstaller.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Not a "blocker"
Flags: blocking-aviary1.0+ → blocking-aviary1.0-

Comment 5

14 years ago
(In reply to comment #2)
> Same thing happens to Netscape 7.1/7.2. Last time I uninstalled FF (FF
> 0.9.3), it also made Netscape 7.2 non-default mail app.

I just encountered this same issue with the 1.0PR uninstaller on Win 98 (after
Software Update to Firefox RC1 failed).  This was particularly frustrating
because just last weekend I had painstakingly gone through the file associations
by hand to make Netscape load a specific profile by default (by adding the "-P"
option; I'm told that's the only way).  I find it really bizarre that Firefox is
changing file associations that it's never even had.

> Also, FF uninstaller shuts down Netscape and Netscape Quick Launch.

I saw this, too.  Together with the file type mis-association, I was momentarily
terrified that I had just uninstalled or broken my wife's primary browser.

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
Flags: blocking1.8b4?

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4-
I believe this is wfm with the new installer that landed - bug 326580. Reporter, could you please confirm with a latest 1.8.1 branch nightly? Thanks.
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8
(Reporter)

Comment 7

12 years ago
I'm afraid I will not be able to test this since I moved all my computers to Linux and don't use Windows anymore. So someone else will have to check this out.
Well, I know we don't try to reset the default browser on uninstall anymore.
resolving -> wfm
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.