Allow changing FROM address to anything when composing

VERIFIED DUPLICATE of bug 87987

Status

--
enhancement
VERIFIED DUPLICATE of bug 87987
14 years ago
10 years ago

People

(Reporter: bugz743, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

When composing an e-mail, there is a pulldown that allows one to choose among
all the addresses associated with the accounts that have been set up. However,
why cannot one simply type in an arbitrary e-mail address that will appear as
the From: address? 

Why would I want to do this? Not to hide my identity while spamming, but rather,
I use quite a few different e-mail addresses for different purposes. For
example, I use a different e-mail at every commerce site and for every list
serve. If I need to post a message to a list serve or remove myself from it is
often very difficult because they reject my emails since they have the wrong
"From" field. 

I realize that an upcoming version of Mozilla will have the capacity to
associate multiple identities to a single account. This is a (small) step in the
right direction, but it would be much simpler to just let me type in the From
address.

 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 87987 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.