Error during make on Linux for IBM zSeries (mainframe) in xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp

RESOLVED WORKSFORME

Status

()

Core
XPConnect
--
major
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Dirk Schwartzkopff, Unassigned)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

c++ -o xptcinvoke_linux_s390x.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\"
-DEXPORT_XPTC_API   -I../../../../../../dist/include/xpcom
-I../../../../../../dist/include -I/mnt/dist/include/nspr     -I./../..
-I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions
-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_al13808 -DTRACING -g
-fno-inline  -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../../../../../mozilla-config.h -Wp,-MD,.deps/xptcinvoke_linux_s390x.pp
xptcinvoke_linux_s390x.cpp
xptcinvoke_linux_s390x.cpp: In function `nsresult
   XPTC_InvokeByIndex(nsISupports*, unsigned int, unsigned int,
   nsXPTCVariant*)':
xptcinvoke_linux_s390x.cpp:194: can't find a register in class `GENERAL_REGS'
   while reloading `asm'


Reproducible: Always
Steps to Reproduce:
1. ./configure
2. make

Actual Results:  
see details


This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:870: checking host system type
configure:891: checking target system type
configure:909: checking build system type
configure:1958: checking for gcc
configure:2071: checking whether the C compiler (gcc  ) works
configure:2087: gcc -o conftest    conftest.c  1>&5
configure:2113: checking whether the C compiler (gcc  ) is a cross-compiler
configure:2118: checking whether we are using GNU C
configure:2127: gcc -E conftest.c
configure:2146: checking whether gcc accepts -g
configure:2182: checking for c++
configure:2214: checking whether the C++ compiler (c++  ) works
configure:2230: c++ -o conftest    conftest.C  1>&5
configure:2256: checking whether the C++ compiler (c++  ) is a cross-compiler
configure:2261: checking whether we are using GNU C++
configure:2270: c++ -E conftest.C
configure:2289: checking whether c++ accepts -g
configure:2338: gcc -c   conftest.c 1>&5
configure:2355: gcc -c   conftest.c 1>&5
configure:2374: checking for ranlib
configure:2406: checking for as
configure:2447: checking for ar
configure:2482: checking for ld
configure:2517: checking for strip
configure:2552: checking for windres
configure:2636: checking for gawk
configure:3006: checking whether gcc and cc understand -c and -o together
configure:3021: gcc -c conftest.c -o conftest.o 1>&5
configure:3022: gcc -c conftest.c -o conftest.o 1>&5
configure:3027: cc -c conftest.c 1>&5
configure:3029: cc -c conftest.c -o conftest.o 1>&5
configure:3030: cc -c conftest.c -o conftest.o 1>&5
configure:3091: checking how to run the C preprocessor
configure:3112: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3171: checking how to run the C++ preprocessor
configure:3189: c++ -E  conftest.C >/dev/null 2>conftest.out
configure:3225: checking for a BSD compatible install
configure:3278: checking whether ln -s works
configure:3303: checking for perl5
configure:3303: checking for perl
configure:3343: checking for minimum required perl version >= 5.004
configure:3353: checking for full perl installation
configure:3366: checking for doxygen
configure:3402: checking for whoami
configure:3438: checking for autoconf
configure:3474: checking for unzip
configure:3512: checking for zip
configure:3553: checking for makedepend
configure:3588: checking for xargs
configure:3718: checking for gmake
configure:3784: checking for X
configure:4098: checking for dnet_ntoa in -ldnet
configure:4117: gcc -o conftest    conftest.c -ldnet   1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -ldnet
collect2: ld returned 1 exit status
configure: failed program was:
#line 4106 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:4139: checking for dnet_ntoa in -ldnet_stub
configure:4158: gcc -o conftest    conftest.c -ldnet_stub   1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -ldnet_stub
collect2: ld returned 1 exit status
configure: failed program was:
#line 4147 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:4187: checking for gethostbyname
configure:4215: gcc -o conftest    conftest.c  1>&5
configure:4285: checking for connect
configure:4313: gcc -o conftest    conftest.c  1>&5
configure:4377: checking for remove
configure:4405: gcc -o conftest    conftest.c  1>&5
configure:4469: checking for shmat
configure:4497: gcc -o conftest    conftest.c  1>&5
configure:4570: checking for IceConnectionNumber in -lICE
configure:4589: gcc -o conftest    -L/usr/X11R6/lib64 conftest.c -lICE   1>&5
configure:4849: checking whether ld has archive extraction flags
configure:4873: gcc -o conftest    -I/usr/X11R6/include -Wl,--whole-archive
conftest.c -Wl,--no-whole-archive 1>&5
configure:4906: checking for 64-bit OS
configure:4916: gcc -o conftest    -I/usr/X11R6/include  conftest.c  1>&5
configure:6074: checking for ANSI C header files
configure:6087: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:6154: gcc -o conftest    -I/usr/X11R6/include  conftest.c  1>&5
configure:6178: checking for working const
configure:6232: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6253: checking for mode_t
configure:6286: checking for off_t
configure:6319: checking for pid_t
configure:6352: checking for size_t
configure:6385: checking for uid_t in sys/types.h
configure:6419: checking for st_blksize in struct stat
configure:6432: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6453: checking for siginfo_t
configure:6466: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6500: checking for int16_t
configure:6513: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6535: checking for int32_t
configure:6548: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6570: checking for int64_t
configure:6583: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6605: checking for int64
configure:6618: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure: In function `main':
configure:6614: `int64' undeclared (first use in this function)
configure:6614: (Each undeclared identifier is reported only once
configure:6614: for each function it appears in.)
configure:6614: parse error before "foo"
configure: failed program was:
#line 6610 "configure"
#include "confdefs.h"
#include <stdio.h>
                  #include <sys/types.h>
int main() {
int64 foo = 0;
; return 0; }
configure:6640: checking for uint
configure:6653: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:6675: checking for uint_t
configure:6688: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure: In function `main':
configure:6684: `uint_t' undeclared (first use in this function)
configure:6684: (Each undeclared identifier is reported only once
configure:6684: for each function it appears in.)
configure:6684: parse error before "foo"
configure: failed program was:
#line 6680 "configure"
#include "confdefs.h"
#include <stdio.h>
                  #include <sys/types.h>
int main() {
uint_t foo = 0;
; return 0; }
configure:6710: checking for uint16_t
configure:6723: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure: In function `main':
configure:6719: `uint16_t' undeclared (first use in this function)
configure:6719: (Each undeclared identifier is reported only once
configure:6719: for each function it appears in.)
configure:6719: parse error before "foo"
configure: failed program was:
#line 6715 "configure"
#include "confdefs.h"
#include <stdio.h>
                  #include <sys/types.h>
int main() {
uint16_t foo = 0;
; return 0; }
configure:6754: checking for uname.domainname
configure:6767: c++ -c    -I/usr/X11R6/include conftest.C 1>&5
configure:6791: checking for uname.__domainname
configure:6804: c++ -c    -I/usr/X11R6/include conftest.C 1>&5
configure: In function `int main()':
configure:6800: `struct utsname' has no member named `__domainname'
configure: failed program was:
#line 6796 "configure"
#include "confdefs.h"
#include <sys/utsname.h>
int main() {
 struct utsname *res; char *domain;
            (void)uname(res);  if (res != 0) { domain = res->__domainname; } 
; return 0; }
configure:6837: checking for usable wchar_t (2 bytes, unsigned)
configure:6852: gcc -o conftest    -I/usr/X11R6/include  conftest.c  1>&5
configure: failed program was:
#line 6845 "configure"
#include "confdefs.h"
#include <stddef.h>
                 int main () {
                   return (sizeof(wchar_t) != 2) ||
                          (wchar_t)-1 < (wchar_t) 0 ; } 
configure:6887: checking for compiler -fshort-wchar option
configure:6902: c++ -o conftest  -fshort-wchar   -I/usr/X11R6/include 
conftest.C  1>&5
configure:6938: checking for .hidden assembler directive
configure:6946: gcc -c  conftest.s 1>&5
configure:6958: checking whether __attribute__((visibility())) is supported
configure:6990: checking for dirent.h that defines DIR
configure:7003: gcc -c    -I/usr/X11R6/include conftest.c 1>&5
configure:7028: checking for opendir in -ldir
configure:7047: gcc -o conftest    -I/usr/X11R6/include  conftest.c -ldir   1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -ldir
collect2: ld returned 1 exit status
configure: failed program was:
#line 7036 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char opendir();

int main() {
opendir()
; return 0; }
configure:7120: checking for sys/byteorder.h
configure:7130: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7126:27: sys/byteorder.h: No such file or directory
configure: failed program was:
#line 7125 "configure"
#include "confdefs.h"
#include <sys/byteorder.h>
configure:7120: checking for compat.h
configure:7130: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7126:20: compat.h: No such file or directory
configure: failed program was:
#line 7125 "configure"
#include "confdefs.h"
#include <compat.h>
configure:7120: checking for getopt.h
configure:7130: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7160: checking for sys/bitypes.h
configure:7170: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7160: checking for memory.h
configure:7170: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7160: checking for unistd.h
configure:7170: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7200: checking for gnu/libc-version.h
configure:7210: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7200: checking for nl_types.h
configure:7210: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7240: checking for malloc.h
configure:7250: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7280: checking for X11/XKBlib.h
configure:7290: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7321: checking for sys/statvfs.h
configure:7331: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7321: checking for sys/statfs.h
configure:7331: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7321: checking for sys/vfs.h
configure:7331: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7321: checking for sys/mount.h
configure:7331: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7362: checking for mmintrin.h
configure:7372: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7368:22: mmintrin.h: No such file or directory
configure: failed program was:
#line 7367 "configure"
#include "confdefs.h"
#include <mmintrin.h>
configure:7409: checking for new
configure:7419: c++ -E   -I/usr/X11R6/include conftest.C >/dev/null 2>conftest.out
configure:7460: checking for sys/cdefs.h
configure:7470: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7504: checking for gethostbyname_r in -lc_r
configure:7523: gcc -o conftest    -I/usr/X11R6/include  conftest.c -lc_r   1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lc_r
collect2: ld returned 1 exit status
configure: failed program was:
#line 7512 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gethostbyname_r();

int main() {
gethostbyname_r()
; return 0; }
configure:7553: checking for atan in -lm
configure:7572: gcc -o conftest    -I/usr/X11R6/include  conftest.c -lm   1>&5
configure:7606: checking for dlopen in -ldl
configure:7625: gcc -o conftest    -I/usr/X11R6/include  conftest.c -ldl  -lm  1>&5
configure:7642: checking for dlfcn.h
configure:7652: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:7787: checking for socket in -lsocket
configure:7806: gcc -o conftest    -I/usr/X11R6/include  conftest.c -lsocket 
-ldl -lm  1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lsocket
collect2: ld returned 1 exit status
configure: failed program was:
#line 7795 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char socket();

int main() {
socket()
; return 0; }
configure:7851: checking for XDrawLines in -lX11
configure:7870: gcc -o conftest    -I/usr/X11R6/include  -L/usr/X11R6/lib64 
conftest.c -lX11 -lX11  -ldl -lm  1>&5
configure:7892: checking for XextAddDisplay in -lXext
configure:7911: gcc -o conftest    -I/usr/X11R6/include  -L/usr/X11R6/lib64 
conftest.c -lXext -lX11  -ldl -lm  1>&5
configure:7935: checking for XtFree in -lXt
configure:7954: gcc -o conftest    -I/usr/X11R6/include  -L/usr/X11R6/lib64 
conftest.c -lXt  -ldl -lm  1>&5
configure:8108: checking for XineramaIsActive in -lXinerama
configure:8127: gcc -o conftest    -I/usr/X11R6/include  -L/usr/X11R6/lib64 
conftest.c -lXinerama -lX11  -lXext -ldl -lm  1>&5
configure:8149: checking for X11/extensions/Xinerama.h
configure:8159: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:8182: checking for XShmCreateImage in -lXext
configure:8201: gcc -o conftest    -I/usr/X11R6/include  -L/usr/X11R6/lib64 
conftest.c -lXext -lX11  -lXext -ldl -lm  1>&5
configure:8223: checking for X11/extensions/XShm.h
configure:8233: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:8263: checking for XieFloGeometry in -lXIE
configure:8282: gcc -o conftest    -I/usr/X11R6/include  -L/usr/X11R6/lib64 
conftest.c -lXIE -lX11  -lXext -ldl -lm  1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lXIE
collect2: ld returned 1 exit status
configure: failed program was:
#line 8271 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char XieFloGeometry();

int main() {
XieFloGeometry()
; return 0; }
configure:8304: checking for X11/extensions/XIElib.h
configure:8314: gcc -E   -I/usr/X11R6/include conftest.c >/dev/null 2>conftest.out
configure:8310:35: X11/extensions/XIElib.h: No such file or directory
configure: failed program was:
#line 8309 "configure"
#include "confdefs.h"
#include <X11/extensions/XIElib.h>
configure:8388: checking for freetype-config
configure:8424: checking for FreeType - version >= 6.1.0
configure:8498: gcc -o conftest  -I/usr/include/freetype2   -I/usr/X11R6/include
 conftest.c -L/usr/lib64 -lfreetype -ldl -lm  1>&5
configure:8550: checking for pthread_create in -lpthreads
gcc -o dummy dummy.c    -I/usr/X11R6/include -lpthreads  -ldl -lm
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lpthreads
collect2: ld returned 1 exit status
configure:8572: checking for pthread_create in -lpthread
gcc -o dummy dummy.c    -I/usr/X11R6/include -lpthread  -ldl -lm 
configure:8672: checking whether gcc accepts -pthread
configure:8826: checking whether mmap() sees write()s
configure:8869: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8894: checking whether gcc needs -traditional
configure:8940: checking for 8-bit clean memcmp
configure:8958: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for random
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for strerror
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for lchown
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for fchmod
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for snprintf
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for statvfs
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for memmove
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:8978: checking for rint
configure:9006: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9033: checking for flockfile
configure:9061: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9033: checking for getpagesize
configure:9061: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9090: checking for localtime_r
configure:9118: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9090: checking for strtok_r
configure:9118: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9154: checking for wcrtomb
configure:9166: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include 
conftest.C -ldl -lm  1>&5
configure:9186: checking for mbrtowc
configure:9198: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include 
conftest.C -ldl -lm  1>&5
configure:9227: checking for res_ninit()
configure:9244: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9274: checking for gnu_get_libc_version()
configure:9290: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include 
conftest.C -ldl -lm  1>&5
configure:9319: checking for iconv in -lc
configure:9341: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include 
conftest.C -lc  -ldl -lm  1>&5
configure:9450: checking for iconv()
configure:9469: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include 
conftest.C -ldl -lm   1>&5
configure:9492: checking for iconv() with const input
configure:9512: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include conftest.C
1>&5
configure: In function `int main()':
configure:9506: invalid conversion from `const char**' to `char**'
configure: failed program was:
#line 9497 "configure"
#include "confdefs.h"

            #include <stdlib.h>
            #include <iconv.h>

int main() {

                const char *input = "testing";
                iconv_t h = iconv_open("", "");
                iconv(h, &input, NULL, NULL, NULL);
                iconv_close(h);
            
; return 0; }
configure:9541: checking for nl_langinfo and CODESET
configure:9553: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include 
conftest.C -ldl -lm  1>&5
configure:9585: checking for an implementation of va_copy()
configure:9609: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9626: checking for an implementation of __va_copy()
configure:9650: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure:9667: checking whether va_lists can be copied by value
configure:9691: gcc -o conftest  -pthread   -I/usr/X11R6/include  conftest.c
-ldl -lm  1>&5
configure: In function `f':
configure:9683: incompatible types in assignment
configure: failed program was:
#line 9677 "configure"
#include "confdefs.h"

        #include <stdarg.h>
        void f (int i, ...) {
            va_list args1, args2;
            va_start (args1, i);
            args2 = args1;
            if (va_arg (args2, int) != 42 || va_arg (args1, int) != 42)
                exit (1);
            va_end (args1); va_end (args2);
        }
        int main() { f (0, 42); return 0; }
configure:9787: checking for C++ exceptions flag
configure:9822: checking for gcc 3.0 ABI
configure:9840: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include conftest.C
1>&5
configure:9861: checking for C++ "explicit" keyword
configure:9876: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include conftest.C
1>&5
configure:9897: checking for C++ "typename" keyword
configure:9921: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include conftest.C
1>&5
configure:9942: checking for modern C++ template specialization syntax support
configure:9957: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include conftest.C
1>&5
configure:9979: checking whether partial template specialization works
configure:9992: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include conftest.C
1>&5
configure:10013: checking whether operators must be re-defined for templates
derived from templates
configure:10030: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10052: checking whether we need to cast a derived template to pass as
its base class
configure:10066: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10087: checking whether the compiler can resolve const ambiguities for
templates
configure:10113: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10135: checking whether the C++ "using" keyword can change access
configure:10148: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10159: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10187: checking whether the C++ "using" keyword resolves ambiguity
configure:10208: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10229: checking for "std::" namespace
configure:10241: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10262: checking whether standard template operator!=() is ambiguous
configure:10277: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10299: checking for C++ reinterpret_cast
configure:10312: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10333: checking for C++ dynamic_cast to void*
configure:10357: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include
 conftest.C -ldl -lm  1>&5
configure:10381: checking whether C++ requires implementation of unused virtual
methods
configure:10393: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include
 conftest.C -ldl -lm  1>&5
configure:10387: warning: all member functions in class `X' are private
/tmp/cc0dEPuC.o: In function `X::X[in-charge]()':
/tmp/cc0dEPuC.o(.gnu.linkonce.t._ZN1XC1Ev+0x26): undefined reference to `vtable
for X'
collect2: ld returned 1 exit status
configure: failed program was:
#line 10386 "configure"
#include "confdefs.h"
class X {private: virtual void never_called();};
int main() {
X x;
; return 0; }
configure:10416: checking for trouble comparing to zero near std::operator!=()
configure:10432: c++ -c  -fshort-wchar -pthread   -I/usr/X11R6/include
conftest.C 1>&5
configure:10464: checking for LC_MESSAGES
configure:10476: gcc -c  -pthread   -I/usr/X11R6/include conftest.c 1>&5
configure:11111: checking for gtk-config
configure:11146: checking for GTK - version >= 1.2.0
configure:11247: gcc -o conftest  -pthread -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib64/glib/include -I/usr/X11R6/include  
-I/usr/X11R6/include  conftest.c -ldl -lm  -L/usr/lib64 -L/usr/X11R6/lib64 -lgtk
-lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm 1>&5
configure:11879: checking for XpGetPrinterList in -lXp
configure:11898: gcc -o conftest  -pthread   -I/usr/X11R6/include 
-L/usr/X11R6/lib64  conftest.c -lXp -lXext -lX11  -ldl -lm  1>&5
configure:12425: checking for gssapi.h
configure:12435: gcc -E   -I/usr/X11R6/include -I/usr/include conftest.c
>/dev/null 2>conftest.out
cpp0: warning: changing search order for system directory "/usr/include"
cpp0: warning:   as it has already been specified as a non-system directory
configure:12431:20: gssapi.h: No such file or directory
configure: failed program was:
#line 12430 "configure"
#include "confdefs.h"
#include <gssapi.h>
configure:12466: checking for gssapi/gssapi.h
configure:12476: gcc -E   -I/usr/X11R6/include -I/usr/include conftest.c
>/dev/null 2>conftest.out
cpp0: warning: changing search order for system directory "/usr/include"
cpp0: warning:   as it has already been specified as a non-system directory
configure:12472:27: gssapi/gssapi.h: No such file or directory
configure: failed program was:
#line 12471 "configure"
#include "confdefs.h"
#include <gssapi/gssapi.h>
configure:12506: checking for gss_init_sec_context in -lgss
configure:12525: gcc -o conftest  -pthread   -I/usr/X11R6/include   -L/usr/lib
conftest.c -lgss  -ldl -lm  1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lgss
collect2: ld returned 1 exit status
configure: failed program was:
#line 12514 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gss_init_sec_context();

int main() {
gss_init_sec_context()
; return 0; }
configure:12549: checking for main in -lk5crypto
configure:12564: gcc -o conftest  -pthread   -I/usr/X11R6/include   -L/usr/lib
conftest.c -lk5crypto  -ldl -lm  1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lk5crypto
collect2: ld returned 1 exit status
configure: failed program was:
#line 12557 "configure"
#include "confdefs.h"

int main() {
main()
; return 0; }
configure:12622: checking for gss_init_sec_context
configure:12650: gcc -o conftest  -pthread   -I/usr/X11R6/include   -L/usr/lib
conftest.c -ldl -lm  -L/usr/lib -lgssapi_krb5 -lkrb5 1>&5
/usr/lib64/gcc-lib/s390x-suse-linux/3.2/../../../../s390x-suse-linux/bin/ld:
cannot find -lgssapi_krb5
collect2: ld returned 1 exit status
configure: failed program was:
#line 12627 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char gss_init_sec_context(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gss_init_sec_context();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_gss_init_sec_context) || defined (__stub___gss_init_sec_context)
choke me
#else
gss_init_sec_context();
#endif

; return 0; }
configure:13882: checking for __cxa_demangle
configure:13913: c++ -o conftest  -fshort-wchar -pthread   -I/usr/X11R6/include
 conftest.C -ldl -lm  1>&5
configure:14051: checking for gcc -pipe support
configure:14073: gcc -c  -pthread -pipe   -I/usr/X11R6/include conftest.c 1>&5
configure:14115: checking whether compiler supports -Wno-long-long
configure:14124: gcc -c  -pthread -pipe -Wno-long-long   -I/usr/X11R6/include
conftest.c 1>&5
configure:14145: checking whether C compiler supports -fprofile-generate
configure:14154: gcc -c  -pthread -pipe -fprofile-generate  
-I/usr/X11R6/include conftest.c 1>&5
cc1: unrecognized option `-fprofile-generate'
configure: failed program was:
#line 14147 "configure"
#include "confdefs.h"

int main() {
return 0;
; return 0; }
configure:14172: checking whether C compiler supports -fprofile-arcs
configure:14181: gcc -c  -pthread -pipe -fprofile-arcs   -I/usr/X11R6/include
conftest.c 1>&5
configure:14227: checking whether C++ compiler has -pedantic long long bug
configure:14238: c++ -o conftest  -fshort-wchar -pthread -pipe  -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic  
-I/usr/X11R6/include  conftest.C -ldl -lm  1>&5
configure:14270: checking for correct overload resolution with const and templates
configure:14305: c++ -c  -fshort-wchar -pthread -pipe  -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -pedantic   -I/usr/X11R6/include conftest.C
1>&5
configure:14773: checking for glib-config
configure:14808: checking for GLIB - version >= 1.2.0
configure:14907: gcc -o conftest  -pthread -pipe -I/usr/include/glib-1.2
-I/usr/lib64/glib/include   -I/usr/X11R6/include  conftest.c -L/usr/lib64 -lglib
-ldl -lm  1>&5
configure:14995: checking for libIDL-config
configure:15030: checking for libIDL - version >= 0.6.3
configure:15143: gcc -o conftest  -pthread -pipe -I/usr/include/glib-1.2
-I/usr/lib64/glib/include -I/usr/include/libIDL-1.0 -I/usr/include/glib-1.2
-I/usr/lib64/glib/include   -I/usr/X11R6/include  conftest.c -L/usr/lib64 -lglib
-L/usr/lib64 -lIDL -lglib -ldl -lm  1>&5
configure:16518: gcc -c -Wall -W -Wno-unused -Wpointer-arith -Wcast-align
-Wno-long-long -pedantic -pthread -pipe  -I/usr/X11R6/include  
-I/usr/X11R6/include conftest.c 1>&5
configure: In function `main':
configure:16512: warning: implicit declaration of function `exit'
(Reporter)

Comment 1

14 years ago
Sorry, forgot buitld identifier:
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.9.1/firefox-0.9.1-source.tar.bz2
Has nothing to do with windows.
(Reporter)

Comment 2

14 years ago
Same bug in 
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.9.3/firefox-0.9.3-source.tar.bz2
(as expected)

Comment 3

13 years ago
*** Bug 267973 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: bryner → nobody
Component: Build Config → Build Config
Product: Firefox → Browser
QA Contact: asa → core.build-config
Version: unspecified → Trunk
>xptcinvoke_linux_s390x.cpp:194: can't find a register in class `GENERAL_REGS'
>   while reloading `asm'

please file compiler bugs with the compiler creator, thanks
(http://gcc.gnu.org/bugs.html)

also, please use the "create new attachment" function for large files, instead
of putting them into comments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
(Reporter)

Comment 5

13 years ago
See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=18630

It is not a compiler error, because "it was an error message correctly
explaining that (and why) a specific inline assembly statment could not be
compiled."

 ------- Additional Comment #6 From Ulrich Weigand  2004-11-24 13:27  [reply]
-------

The inline assembly statement is impossible to reload under the
given circumstances.  Note that the statement requires 12 general
purpose registers at the same time (6 inputs and 6 clobbers), but
using the options you give, GCC 3.2 has only 11 general purpose
registers available for general use (namely %r0 .. %r10;  %r11 is
the frame pointer, %r12 the GOT pointer, %r13 the literal pool
pointer, %r14 the return address register and %r15 the stack pointer).

You could either
 - rewrite the assembly to require one fewer register
 - build with -O (or -fomit-frame-pointer) to free up %r11
 - build without -fPIC to free up %r12 (probably impossible)
 - use GCC 3.4 (as this makes %r14 available for general use)

I'd recommend to simply use -O2.

I tried -O2 and it worked fine. But I had to add the compiler option manually.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
ok then, cc'ing some people who may be able to help.

(note that your second problem is an indication that you didn't follow the build
instructions quite correctly, please see
http://www.mozilla.org/projects/firefox/build.html for the instructions)
Assignee: nobody → dbradley
Component: Build Config → XPConnect
Product: Mozilla Application Suite → Core
QA Contact: core.build-config → pschwartau
for example

CFLAGS=-O2 -fsigned-char -fno-strict-aliasing
CXXFLAGS=-O2 -fsigned-char -fno-strict-aliasing

exported before configure/make seems to work fine.
So the only thing what could be missing is a configure check for -O2 or similar
for s390x architecture.
Or do I miss the point?
(Reporter)

Comment 8

13 years ago
The configure check for -O2 or similar for s390x architecture is exactly what (I
think) should be done because it is difficult to find out what happend if you
don't specify -O2.
This still happens with firefox 1.5beta1, and I couldn't find any combination of
gcc flags that are able to compile the code. The xptcinvoke_linux_s390.cpp file
compiles fine, though.
Assignee: dbradley → nobody
QA Contact: pschwartau → xpconnect
This should build fine, now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372428
Sorry, the issue was different.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Is this still an issue ?
Flags: needinfo?(Dirk.Schwartzkopff)
It works on Debian, and has for a while.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

5 years ago
This bug is more than 8 years old. I haven't tried it for a long time. You should close this bug.
Flags: needinfo?(Dirk.Schwartzkopff)
You need to log in before you can comment on or make changes to this bug.