Closed Bug 249900 Opened 18 years ago Closed 18 years ago

"URL open" feature integration to Windows OS is partially broken on my computer

Categories

(Firefox :: Shell Integration, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 246078

People

(Reporter: public, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Prior to installing Firefox, I had Netscape 4.8, Internet Explorer
6.0.2800.1106.xpsp2.030422-1633 installed on Windows XP.

I installed Firefox and set it to be the default browser. 

When I open a URL from another program, Firefox will correctly load the URL, but
the application seems also to receive a signal from the OS that it doesn't know
how to load a URL (as if now URL handling software were assigned as default).

For example, I go to Start->Run->http://www.mit.edu (or any URL) and Firefox
loads the URL and then Windows displays this message (the URL seems to load
completely before Windows displays this message):

Windows cannot find "http://www.mit.edu" Make sure you typed it in correctly and
try again.<snip>

Now, if I run Internet Explorer (but with Firefox still as default browser) the
URL will load correctly in Explorer with no error. (This is annoying because
Explorer shouldn't grab the URL handler but it does, and it also demonstrates
that something weird is going on because the error message does not occur).

Similarly, if I open my email client (Eudora 6.1.1) and click on a URL link
there, Firefox will correctly open the link. When it is done loading, Eudora
pops up a file selection box with the title:

Choose Program to Open "http://<snip>"

Somehow the OS seems to be telling the calling application that the link can't
be loaded. 

I hope this is enough information. I am assuming there must be something "bent"
about my particular configuration as this problem seems to big to be a common issue.

Reproducible: Always
Steps to Reproduce:
1.(Unknown configuration set up required: mine is IE 6, Netscape 4.8 and Firefox
(as default browser)
2. WindowsXP->Start Button->Run->http://www.mit.edu (or any link)
3. Firefox loads link and then Windows reports error (cited above in "Details"
section)

Actual Results:  
Link loads in Firefox but Windows seems to think it failed to load. Client
applications seems to get a message that there is no default URL handler or
perhaps they get an undefined error that is interpreted that way.

Expected Results:  
Firefox should load the selected URL and no error messages should be displayed
by Windows or client application.

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.