False procentage calculation

VERIFIED DUPLICATE of bug 245829

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 245829
14 years ago
10 years ago

People

(Reporter: Jure Tomazic, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

I started a download of a 711 MByte .iso file from a FTP server. The procentage
of  donloaded file was calculated correctly. An hour later, when first download
was about half way, I started downloading annother 700 MByte iso. The procentage
( both downloads together ) was calculated correctly. However, when the first
file was downloaded, procentage was miscalculated. It indicatd that the file was
30% downloaded, although about 500 of 700MByte were downloaded. So when the
second file was almost fully downloaded it showed 50%.

This shows that the procentage was calculated in the following way:
file2 / (file1 + file2)

I suggest you make ( or fix ) a rutene, which updates the sum of all sizes of
currently downloading files, whenever any file, within the list, is downloaded.  

Reproducible: Always
Steps to Reproduce:
1.Go to a ftp server and start downloading any large .iso file
2.When the file is about half way downloaded, start downloading another one
3.Wait until the second one is downloaded.

Actual Results:  
Procentage is miscalculated.

Expected Results:  
Showed correct procentage - calculated from the sum of all CURENTLY downloading
files.

I have a 1MBit ADSL connection.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 245725 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 245829 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.