Closed Bug 250267 Opened 17 years ago Closed 16 years ago

Starting a download freezes browser window ([Not Responding]) until DL-mgr window appears

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 159107

People

(Reporter: mozilla-bugzilla, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When starting a download by clicking on a link, Firefox becomes unresponsive for
several seconds (approx. 10) until Download Manager is displayed and indicates
download is in progress.

During the browser window freeze, Window decorations are painted (border +
minimize/restore/close buttons) but inner window remains empty.

CPU is pegged at 100%; Firefox consumes all CPU.

Hardware: multiple laptops; Intel PIII 1GHz and Mobile AMD Athlon 4 1600+; 256MB
RAM each.

Issue occurs with and without proxy.


Reproducible: Always
Steps to Reproduce:
1. Start download of a file, e.g. an ISO file from linuxiso.org
2.
3.

Actual Results:  
Browser window freezes, while the download (DL Manager) is apparently being
started in the background.

Download Manager window does not appear for several seconds, possibly waiting
until data is actually being received.

CPU, meanwhile, stays pegged at 100%.

When trying to switch to another window, XP considers application "[Not
Responding]".

Download Manager starts responding after a while (perhaps as soon as data is
being received?); this "unfreezes" the browser.

Expected Results:  
Browser windows should remain usable. Download should start smoothly in the
background.

Firefox 0.9.1 with "fix" XPI from release notes installed. Patch does not appear
to solve the issue.

I'm initially classifying this as "critical" since from the user experience, the
application hangs. However, it does recover if you are patient...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Hardware: PIV 2.8, 512MB ram and a 10MBit connection.

I've been unable to reproduce this bug. Clicking on any of the different files I
tried on linuxiso.org added no more then 6% CPU load even when it needed several
seconds to get contact with the server. I run no proxy, firewall or anything active.

A guess for this bug could be that it only happens between the moment Firefox
actually gets contact with the server and starts a download until it got enough
info to pop-up the dialog, and would only appear when trying to download over a
slow connection (or from a over loaded server).
Oops, I forgot to add my environment specs:

- Asus P4C 800E DeLuxe
- P4, 3GHz HT, 800MHz FSB, 2 x 512MB RAM
- 2Mbps ADSL
- Firefox 0.9.1
- WinXP Pro SP1a with all updates applied.

I've reproduced it just now using
http://www.linuxiso.org/download.php/350/valhalla-i386-disc2.iso

New observation: firefox.exe memory use grows rapidly while browser "hangs".

I checked this using Windows Task Manager.

- Firefox memory use idles around 20MB.
- Open www.linuxiso.org: grows slowly to approx. 22MB
- Choose RedHat: no noticeable effect
- Click "disc 2" link: rapid growth to to 35 - 43MB; browser "hangs"

Hope this helps,

Greetings,
  Ed.
*** Bug 257886 has been marked as a duplicate of this bug. ***
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1
> 
> When starting a download by clicking on a link, Firefox becomes unresponsive for
> several seconds (approx. 10) until Download Manager is displayed and indicates
> download is in progress.
> 
> During the browser window freeze, Window decorations are painted (border +
> minimize/restore/close buttons) but inner window remains empty.
> 
> CPU is pegged at 100%; Firefox consumes all CPU.
> 
> Hardware: multiple laptops; Intel PIII 1GHz and Mobile AMD Athlon 4 1600+; 256MB
> RAM each.
> 
> Issue occurs with and without proxy.
> 
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. Start download of a file, e.g. an ISO file from linuxiso.org
> 2.
> 3.
> 
> Actual Results:  
> Browser window freezes, while the download (DL Manager) is apparently being
> started in the background.
> 
> Download Manager window does not appear for several seconds, possibly waiting
> until data is actually being received.
> 
> CPU, meanwhile, stays pegged at 100%.
> 
> When trying to switch to another window, XP considers application "[Not
> Responding]".
> 
> Download Manager starts responding after a while (perhaps as soon as data is
> being received?); this "unfreezes" the browser.
> 
> Expected Results:  
> Browser windows should remain usable. Download should start smoothly in the
> background.
> 
> Firefox 0.9.1 with "fix" XPI from release notes installed. Patch does not appear
> to solve the issue.
> 
> I'm initially classifying this as "critical" since from the user experience, the
> application hangs. However, it does recover if you are patient...

(In reply to comment #3)
> *** Bug 257886 has been marked as a duplicate of this bug. ***

CRITICAL! - see thread:
http://savanna.mozillazine.org/viewtopic.php?t=148183&highlight=
I'm on a Dell 4400 2GHz, 1G RAM, cable connection, running XP home.

***This problem only occurs with Acrobat PDF documents on my system***

In firefox 1.0 (newly installed), the browser has a LOT of problems with PDF
files in the following ways:

1. 100% of the time it freezes the browser after clicking on a PDF link; I used
to wait for it to unfreeze itself but grew tired of that after I finally
installed 1.0 over my old 0.9 firefox and the problem persisted.

2. The only exception to #1 seems to occur if I had previously used Acrobat
externally to the browser before i clikced a PDF link. (Strangely, the Firefox
plugin settings point to acroread32 to read PDF links, but still loads up my
full-on Acrobat Professional 6.0 app every time--what's up with this???).

3. The problem with #2 is that when you exit acrobat (professional, in this
case) it freezes the browser anyway.

4. Sometimes the PDF file opens in its own window and leaves an empty browser
window open upon closing it (after opening the link with "open in new window).

In any case this problem with PDFs is REALLY irritating because it forces me to
shut down the entire browser and restart to get control back.
I can verify that this problem exists with Windows XP SP2 and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Whenever I try to start a download, the download window opens and then Firefox
freezes.  It doesn't matter what I'm trying to download.  I don't have a
download history, as I have it set to clear history on a successful download. 

I did not experience this problem with versions of Firefox prior to 1.0.  This
is a serious annoyance, so I'll probably go back to RC1.
As a follow up to my previous comment.  The downloads have magically started
working.  I didn't change anything, although I did check the download history
settings.  I don't understand this as Firefox has been freezing anytime I
attempt to download since I upgraded to 1.0.

Bugs 270312, 255325, and 261079 appear to be related to this bug.

This is cvs build of firefox (initially noticed since the 1.0 release, did not
occur in the .9 releases that I remember), win xp, I have an ATI graphics card
and am on a laptop.

I get two symptons

1) 100% or near 100% CPU utilization, that sometimes is only a brief spike.
2) However, frequently the entire browser will freeze indefinitely and will have
to be killed.

I can reliably reproduce this bug by initiating 7 or 8 large downloads
simultaneously (large as in 20 mb).  Usually I right click and do save as.

Ie initiate download of all of the links in the demos at this link.

http://www.alias.com/eng/products-services/motionbuilder/index.shtml

Possibly related is that there appears to be a hard disk access caused whenever
a new download is initiated.
This is not an isolated problem.  Occurs on 4 seperate computers that I
use..WinXP, Win2K & Win98SE. The larger the file to be downloaded the longer FF
appears to hang. It freezes longer the first time a file downloaded and the
download manager window is not present. But FF will still appear to freeze with
each following download. After the download has started or finished FF returns
to normal and Windows no longer lists it as "Not Responding".
Very annoying for a fast browser to have a snail download manager.

Longest time for FF to recover from a download was over 10 minutes while
downloading a 15 MB file from someones iDrive website.
always a repeatable phenomon, never a successful download, also trying to 
manipulate dowload manager under preferences cause the same freeze, both 
procedures cause a 100% spike in cpu usage. 

 This build Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) 
Gecko/20050126 Firefox/1.0+ is responsible 

 Machine is 800 mhz thunderbird running win2k over 298 mhz of ram. 

 Firefox works well on the xp machine, which is the only reason I have gone 
through the trouble of reporting this. Since this is a major dissapointment as 
far as browser reliability. 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050322
Firefox/1.0+

Trying to confirm in latest nightly on my laptop, my relevant environment specs are:

2.0GHz Pentium 4 Mobile
512MB of RAM
Windows XP Pro Corporate Service Pack 1 Build 2600 with all updates


I decided to try and grab the Knoppix 3.6 ISO for the purpose of this test.
http://www.linuxiso.org/download.php/327/KNOPPIX_V3.6-2004-08-16-EN.iso

I noticed no hang before the download dialog appeared.  No sudden increases in
system resources according to the Task Manager.
On second glance, this looks like it may be related to the download history bug.    

Reporter, Commentors:  What is the state of your download history when you
reproduce this?
 
it just starts and then freezes ... I uninstalled Firefox since then so I can't 
say anymore
Mozilla Firefox keeps telling me I need a critical update, but freezes
immediately when I OK it - neither the cancel button or anything will work
except to close the update GUI by clicking at the upper right corner.

I even turned off my Windows firewall but no better that way.
I found that clicking the Clean Up button in the download manager reduces if not
eliminates the freezing. Appears that the manager can't manage that many downloads.
I notice a considerable slow down after 10 files are in the download manager queue.
I have the same problem with version 1.0.3 firefox.

I believe it is when I have had about twenty tabs loaded in two or three windows,
and I have possibly closed some of them.
Strangely, the title bar will still get focus and drag the window.
Maybe the CPU priority.
xp home, sp2, autoupdate.

TTFN

*** This bug has been marked as a duplicate of 159107 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Problem is still there in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060616 BonEcho/2.0a3 ID:2006061603

This should be fixed for firefox 2.0 final.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.