file:/// URLs do not work from pages loaded via http

RESOLVED DUPLICATE of bug 122022

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 122022
14 years ago
13 years ago

People

(Reporter: Paul Lynch, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

If I load a page whose address is http://something, and the page has a link to
an URL of the form file:///c:/some/file that points to a file on my local
machine, the link does not work.  Nothing happens when I click on it.  I don't
even get an
error message.  If I right click on the link and choose "copy link location",
and paste that into the location box at the top of the browser window, then the
browser accesses the file without a problem.  Firefox has the same problem, but
IE does not.

I'll grant you that for a publicly available web-page, having a file:/// link in
the page does not make much sense, but it comes in handy for my personal
web-page, from which I would like to be able to access files on my computer, and
which is also available though a web-server.  The file:/// links should work for
me, and should (in most cases) result in "file not found" for anyone else.



Reproducible: Always
Steps to Reproduce:
1. Create a web-page that contains a link to a file with a file:/// URI.
2. Access the web-page through an http URI.
3. Click on the file link.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.