Firefox 0.91 does not launch after installation on iMAC OS X

VERIFIED INVALID

Status

()

Firefox
Installer
--
major
VERIFIED INVALID
14 years ago
12 years ago

People

(Reporter: Allison Gener, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/124 (KHTML, like Gecko) Safari/125.1
Build Identifier: mozilla.org

New download of 0.91 Firefox application will not launch on iMAC running OS X.  I installed over a 
previously installed version of 0.8.   First try I imported bookmarks, etc. from 0.8 install.  Initiating 0.9 
version, icon shows up in finder bar, but then disappears - and no app running.  Removed all files / 
references to Firefox installation, and retried from fresh DMG download.  This time did not import 
bookmarks.  Still, no application running.

Reproducible: Always
Steps to Reproduce:
1.  download distribution
2. unstuff
3. click app to start

Actual Results:  
app failed to launch

Expected Results:  
browser app should have launched

could this be a weird iMAC OS X idiosyncrasies?
is there any known incompatibilities with Sophos virus protection software not recognizing Firefox app 
and killing the new install launch?

Comment 1

14 years ago
Allison,

It could be Sophos... I don't have it nor have I ever used it. May I suggest
that your disable Sophos on your initial launch of Firefox and see if that works?

Comment 2

14 years ago
Same here. OS X 10.3.4, TiBook. FireFox 0.9.1 starts, seems to scan the plugins (and has problems with 
the old Java plug-in, if present - log from Console.app:

JavaVM FATAL: Failed to load the jvm library. Exit
/Volumes/Firefox/Firefox.app/Contents/MacOS/firefox-bin: can't map file: /Library/Internet Plug-Ins/
Java Applet.plugin ((os/kern) invalid argument)
JavaVM FATAL: Failed to load the jvm library. Exit

), then quits without a dialog box or message on the console.

It also quits (just faster) if the /Library/Internet PLug-Ins folder is empty.

Comment 3

14 years ago
Some more tests: 
- On MacOS X 10.2.8, the same TiBook, Firefox launches.
- On MacOS X 10.3.4, with the default user folder, it doesn't launch 
- On MacOS X 10.3.4, with exactly the same user folder as with 10.2.8 [mirrored with an hack], it won't 
launch 
- On 10.3.4, only Java 1.4.2 is installed. Any dependency? 

 

Comment 4

14 years ago
It affects also Firefox 0.93

The reason in my case was the Java 1.3.1 plugin  in /Library/Internet Plug-Ins/Java Applet.plugin and 
no Java version 1.3.1 (only 1.4.x) installed. Removing the plugin allows Firefox to launch.

Comment 5

14 years ago
I have a similar problem, when I try to launch firefox on OS-X the icon bounces in the doc, then goes 
away and comes back, this reapeats untill I do a killall firefox-bin from a shell window.

Comment 6

14 years ago
I have a similar problem, when I try to launch firefox on OS-X the icon bounces in the doc, then goes 
away and comes back, this reapeats untill I do a killall firefox-bin from a shell window.

This is on OS X 10.3 on an iBook G4 with no major changes. 

Comment 7

14 years ago
Reporter, you should never install over an exisiting installation ! 

Comment 8

14 years ago
The overwrite installation on an old version doesn't work normally. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.