Profiles aren't portable after installing extensions/themes

VERIFIED DUPLICATE of bug 246209

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 246209
14 years ago
10 years ago

People

(Reporter: whimboo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
The last days I'm trying to get my profile to work with different OS. So I moved
it to another partition which is accessible from Windows and Linux. 

Without any installed extensions/themes it's working properly. But trying to
share a profile with extensions or themes, the profile sharing doesn't work.
This problem still came up with the integration of the new extension manager for
Firefox and Thunderbird. 

After analyzing the chrome registration I recognized that all extensions and
themes are stored with absolute paths within the chrome.rdf.

c:baseURL="jar:file:///e:/firefox/extensions/%7Bbf591015-b599-4125-9428-3cb746ddca31%7D/chrome/mnenhy.jar!/content/mnenhy/"

This is definetely the wrong way cause this way deny any sharing of profiles.
Instead a relative path should be used for every extension/theme. Cause we know
that they are located within the profile we don't need any absolute path. 

IMO it should be implemented soon.
(Reporter)

Comment 1

14 years ago
Asking for blocking Aviary1.0RC1 cause this a nasty bug which should be fixed.
Flags: blocking-aviary1.0RC1?

Comment 2

14 years ago
Dupe of Bug 246209?
This is covered in bug 246209. It has unfortunately been -'ed by bsmedberg for 1.0.

*** This bug has been marked as a duplicate of 246209 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

14 years ago
v.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Flags: blocking-aviary1.0PR?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.