DNS resolver cache does not expire on dynamic records

RESOLVED DUPLICATE of bug 162871

Status

defect
RESOLVED DUPLICATE of bug 162871
15 years ago
15 years ago

People

(Reporter: weigelt, Assigned: darin.moz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

the DNS resolver cache doesnt seem to respect the TTLs of received DNS records,
so when a dynamic hostname (i.e. dyndns) changes, the only chance to access the
site behind is to restart mozilla. 

FIXME: didnt actually check mozilla's DNS traffic yet.


Reproducible: Always
Steps to Reproduce:
1. load some site w/ dynamic hostname
2. move the site to another IP and update the record (or wait until it will be
done, i.e. on DIP-reconnect)
3. try to load this site again

I've using such a dynamic hostname at www.dev.metux.de, its my workstation
behind a DSL line w/ dynamic IP allocation and automatic reconnect once a day.
Try to access my site, leave mozilla opened and try again 24h later.

Comment 1

15 years ago
Darin, could you look into this?  Thanks.

I'm not sure if this is an NSPR bug or a Necko bug.
Assignee: wchang0222 → darin
fixed by bug 205726, for 1.6alpha... you should update mozilla, 1.5 is really old.

note: the C library doesn't tell mozilla about the TTL, so it can't use that.
however, since that patch, mozilla assumes a TTL of a few minutes (five, I
think), and removes the entry from its cache.

*** This bug has been marked as a duplicate of 162871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry, it's 1 minute, not 5:
http://lxr.mozilla.org/seamonkey/source/netwerk/dns/src/nsDNSService2.cpp#285
285     PRUint32 maxCacheLifetime = 1; // minutes
You need to log in before you can comment on or make changes to this bug.