Clicking on WMV file opens What should Firefox do? dialog

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
2 months ago

People

(Reporter: andrewk8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Firefox 0.9.1 does not handle .wmv files very well.

When clicking on a .WMV file to view, Firefox does not play the file.  Instead,
Firefox opens a dialog box "Opening xxx.wmv.  You have chosen to open xxx.wmv
which is a Windows Media Audio/Video file from http:www.xxx.xxx.  What should
Firefox do with this file?"  The default option is to Open With "WMVFile
(default)".  When you click on OK, the Microsoft Media Player launches and it
plays the file.

Firefox displays an option to "Do this automatically for files like this from
now on."  If you check this box, it makes no difference.  You still get the
dialog box the next time you click on a .WMV file.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Firefox does not know how to open .WMV files, even when you tell it to "Do this
automatically for files like this from now on."

Expected Results:  
Firefox should automatically launch Windows Media Player and play the requested
file without prompting.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707
Firefox/0.9.0+
CONFIRMED 
Even though it chooses windows media player it refuses to open it w/o the dialogue
[V]Do this automatically for files like this from now on 
results in a line 
Settings can be changed in the ....Tools,Options.

Even if it is correct under Options it still won't work

changed to NEW

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Same problem on Linux.
Radio for changing application is greyed out and selecting "Open with default
Linux i686 application leads to" alert "OpenDownload (220)".

(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040811
Firefox/0.9.1+)
The website sends the wmv file with a wrong mime-Type (text/plain) and Firefox would display the file as text (!) but we added a workaround that firefox displays the File save as dialog instead.

It's a bug that the "Do this automatically..." is not greyed but not the other things.
We have a bug for duping but I can't find it at the moment.

Updated

12 years ago
QA Contact: ali → file.handling

Comment 5

12 years ago
Confirming the bug for all higher FireFox versions (CZ, EN) from v1.0.8. All these are flawed and keep me asking like crazy. Early v1.0 preview up to v1.0.8 are working flawlessly.
Even updating from 1.0.6 to 1.5.x seems to keep the preferences and the good behaviour, but installing and configuring v1.5.x and later from scratch make the wmv play impossible, because it is extremly annoying to clicking over and over and over on the "remember" checkmark and FireFox NEVER remembering it...
Assignee: bugs → nobody

Comment 6

11 years ago
This bug still persists in Firefox 2.x

I also get this error with some other file types, such as Adobe PDF files. Strangely, if I change the behavior to "download this file" instead of "open this file with" Firefox will remember that behavior. I wonder why there should be this difference between the two different behaviors with the same MIME type.

Comment 7

2 months ago

Closing since Firefox 52 dropped support for NPAPI plug-ins other than Flash, so it's no longer possible to play WMV files. In case the problem at comment 3 has persisted into the current version, please file a new bug report if one doesn't already exist.

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.