Ff 0.9.x crashes when going to games.yahoo.com [@ nsLineLayout::ReflowFrame ]

RESOLVED DUPLICATE of bug 240105

Status

()

--
critical
RESOLVED DUPLICATE of bug 240105
15 years ago
8 years ago

People

(Reporter: tiredintx, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

it happens either using bookmarks or typing it in or starting at Yahoo.com and
going to it manually

Reproducible: Always
Steps to Reproduce:
1.go to url http://games.yahoo.com/games/login2?page=sp&cat=intermediate
2.
3.

Actual Results:  
the browswer window totally disappears

Expected Results:  
gone to the url

no warnings or error reports

Comment 1

15 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040711

Just loading the website from the URL supplied above. 
Is any action required, to get this crashing?
Do you type in Password and ID, or are they filled in automatically by Password
Manager? Is this bug Firefox only, or did you also test on Mozilla?
Do you use extensions?

Comment 2

15 years ago
I could reproduce this. I did have to input my password (it remembered my username).

At first the page was loading in a different tab and that tab was almost
unresponsive, but when I closed the tab Firefox crashed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040706
Firefox/0.9.0+

Comment 3

15 years ago
Some TB IDs, note that for me Firefox crashes *only* if I try to close the
unresponsive tab or window.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040706
Firefox/0.9.0+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: TB308925X TB308951K TB308959W

Updated

15 years ago
Keywords: talkbackid
Summary: broswer crashes and totally disappears when going to this url → Ff 0.9.x crashes and totally disappears when going to this url

Comment 4

15 years ago
TB308925X (TB308951K and TB308959W look same):

nsLineLayout::ReflowFrame 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp,
line 1187]
nsBlockFrame::ReflowInlineFrame 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3733]
nsBlockFrame::DoReflowInlineFrames 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3431]
nsBlockFrame::DoReflowInlineFramesAuto 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3332]
nsBlockFrame::ReflowInlineFrames 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3277]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2441]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3053]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsBlockReflowContext::ReflowBlock 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp,
line 547]
nsBlockFrame::ReflowBlockFrame 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 3053]
nsBlockFrame::ReflowLine 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2316]
nsBlockFrame::ReflowDirtyLines 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 2097]
nsBlockFrame::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 816]
nsContainerFrame::ReflowChild 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
CanvasFrame::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsHTMLFrame.cpp,
line 554]
nsBoxToBlockAdaptor::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 884]
nsBoxToBlockAdaptor::DoLayout 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 626]
nsBox::Layout 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsBox::Layout 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsGfxScrollFrameInner::LayoutBox 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1256]
nsGfxScrollFrame::DoLayout 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1265]
nsBox::Layout 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp,
line 1001]
nsGfxScrollFrame::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 867]
nsContainerFrame::ReflowChild 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 249]
IncrementalReflow::Dispatch 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 900]
PresShell::ProcessReflowCommands 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6366]
ReflowEvent::HandleEvent 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6191]
PL_HandleEvent 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c,
line 674]
SHELL32.dll + 0x4e0c24 (0x778b0c24)
nsHTMLReflowState::nsHTMLReflowState 
[c:/builds/tinderbox/firefox_branch/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 236]
0x2c753039

Bug 240105 has similar stack.

Cheryl, Oleg: What versions of Java do you have (see about:plugins)?

-> Layout
Assignee: general → nobody
Component: Browser-General → Layout
Keywords: talkbackid → crash
QA Contact: general → core.layout
Summary: Ff 0.9.x crashes and totally disappears when going to this url → Ff 0.9.x crashes when going to games.yahoo.com [@ nsLineLayout::ReflowFrame ]
Whiteboard: TB308925X TB308951K TB308959W

Comment 5

15 years ago
mine is 1.4.2_03

Comment 6

15 years ago
Do people crashing have the AdBlock extension installed?  This looks like a dup
of bug 240105.

Comment 7

15 years ago
Also, if you're crashing with Java 1.4.x, try installing 1.5 and report back
with your results.  Thanks.

Comment 8

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040924
Firefox/0.10

This WFM now w/ JRE 1.5.0_b64

I believe it should be marked a dup of bug 240105

Comment 9

15 years ago

*** This bug has been marked as a duplicate of 240105 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsLineLayout::ReflowFrame ]
You need to log in before you can comment on or make changes to this bug.