Mozilla should offer to open "Attachment" links of supported types in browser

VERIFIED DUPLICATE of bug 185618

Status

Core Graveyard
File Handling
--
enhancement
VERIFIED DUPLICATE of bug 185618
14 years ago
a year ago

People

(Reporter: Johan Walles, Unassigned)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Go to https://bugs.eclipse.org/bugs/show_bug.cgi?id=69908

Click "CDT modification proposal for 64-bit support".

A dialog is opened saying that the file is an "attachment" of type text/html and
asks me what I want Mozilla to do with the file.


Current behaviour:
------------------
I can choose between opening it in an external app, or to save it to disk.

Expected behaviour:
-------------------
Since text/html is a MIME type supported by Mozilla I should be allowed the
choice of opening the file inside Mozilla as well.

Comment 1

14 years ago
Server sends:
 1 HTTP/1.1 200 OK
 2 Date: Wed, 14 Jul 2004 01:57:00 GMT
 3 Server: Apache/2.0.40 (Red Hat Linux)
 4 Content-Disposition: attachment; filename=cdt_64_bit_support.htm
 5 Content-Length: 55888
 6 Connection: close
 7 Content-Type: text/html; name="cdt_64_bit_support.htm"; charset=ISO-8859-1

I guess it's "Content-Disposition: attachment" that causes this behaviour.
(Reporter)

Comment 2

14 years ago
Yes, it is.  The dialog box actually says so explicitly.

My point is that Mozilla has one option too little (i.e. "handle this in the
browser" is missing) when handling stuff tagged as "attachment".

Updated

14 years ago
Whiteboard: DUPEME
finally found the original bug

*** This bug has been marked as a duplicate of 185618 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.