pop3 mails moved by message-filter are not deleted from server

RESOLVED DUPLICATE of bug 89034

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 89034
14 years ago
10 years ago

People

(Reporter: Knut Willems, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

using POP3: mails which are moved from INBOX to other folders by
mozilla-message-filters are not deleted from the Server. BUT the option "Server
Settings->Leave Mails on Server-> until I delete or move them from Inbox" is
checked; all mails not moved by Message-Filters are deleted correctly.
so i.a.words only manual moving of mails results in correct behaviour, all
automatically treated mails remain on the server.

Reproducible: Always
Steps to Reproduce:
1.make subfolders in INBOX-Folder called Newsletters
2.make subfolder in the new Folder called Newsletter with the name Java-Newsletter
3.make Message-Filter: Move Mails with the subject java newsletter to the Folder
Java-Newsletter
4.Turn the option Delete Mails from server if they are moved from inbox on.
5. Now you get a Java Newsletter, it will be automatically sorted in the Folder
Java-Newsletter, so moved away from folder INBOX, but it still lives on the server.

Actual Results:  
Now you get a Java Newsletter, it will be automatically sorted in the Folder
Java-Newsletter, so moved away from folder INBOX, but it still lives on the server.

Expected Results:  
delete the messages.

I like the Mozilla Suite.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 89034 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.