Closed Bug 25135 Opened 20 years ago Closed 20 years ago

Address Book: Disable unused menu items for B1

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: phil, Assigned: hangas)

References

Details

(Whiteboard: [PDT+] 1 day after 12051 fixed)

Our decision is to disable unused menu items (rather than remove them) and
precede each un-enable-able item with a '.'
Keywords: beta1
Target Milestone: M14
Status: NEW → ASSIGNED
*** Bug 14257 has been marked as a duplicate of this bug. ***
QA Contact: lchiang → nbaca
Putting no PDT+ radar for beta1.
Whiteboard: [PDT+]
Fix checked in.  Just some changes to xul/js/css.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Build 2000-01-10-08M14: NT4, Linux 6.0, Mac 8.5.1
Reopening

Edit menu: The following should have dots placed in front since they are not 
working:
- Undo
- Redo
- Cut
- Copy (should be grayed out as well)
- Paste

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Since the edit menu items are global they cannot get the dots or they will look 
wrong when they are on a window that has them wired up.  I am working on the copy 
issue.  There is a bug bounce between Hyatt and myself on that problem.
Status: REOPENED → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 2/18
The Copy menu item has been disabled now that 27283 is fixed.  As I said in the 
previous comment Undo, Redo, Cut, Copy, Paste are global features so they cannot 
get "." in front of them without having the "." appear in every window.  Marking 
as fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] 2/18 → [PDT+] 2/11
Build 2000-02-14-16M14: NT4, Linux 6.0
Build 2000-02-14-12M13: Mac 8.6.1
The Copy menu item still appears disabled.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This problem with the Copy menu item is caused by 12051.
Status: REOPENED → ASSIGNED
Depends on: 12051
Whiteboard: [PDT+] 2/11 → [PDT+] depends 12051
Oops, I meant to say the Copy is still "enabled".
Whiteboard: [PDT+] depends 12051 → [PDT+] 1 day after 12051 fixed
Marking fixed because saari reported to me that although 12051 was not fixed he 
thought enough of it was fixed to give us what we need for this bug.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Build 2000-02-23-08M14: NT4, Linux 6.0
Build 2000-02-23-12M14: Mac 8.5.1
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.