If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

all text on page flashing/blinking constantly

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Dan Brennan, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In the page at http://www.pyogenes.com/v2.html/, a large chunk of javascript is
being used (http://www.pyogenes.com/timer3.js).  The script runs a series of
timers on the page, which are constantly running and changing content.  Due to
this (at least I think its due to the JS), the screen and text flash/blink about
every 1-2 seconds.

Reproducible: Always
Steps to Reproduce:
1. Open http://www.pyogenes.com/v2.html/
2. 
3.

Actual Results:  
Blinking/Flashing text and screen 

Expected Results:  
not blinked/flashed and run the timers smoothly (you can see the way it is
"supposed" to look by opening in IE6).

Comment 1

13 years ago
WFM: Using 0.9.2 - nothing blinks.

Comment 2

13 years ago
I can reproduce this. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040712 Firefox/0.9.1+

Comment 3

13 years ago
I can also reproduce this in - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a2) Gecko/20040713

It is a Mozilla bug of some sort. One odd thing is that you can stop the seizure
inducing blinking by moving the mouse around on the page.

Comment 4

13 years ago
(In reply to comment #1)
> WFM: Using 0.9.2 - nothing blinks.
Go to http://boatlifts4less.com/ all text blinks on 0.9.2 also
a_schiro@yahoo.com

Comment 5

13 years ago
(In reply to comment #4)
> (In reply to comment #1)
> > WFM: Using 0.9.2 - nothing blinks.
> Go to http://boatlifts4less.com/ all text blinks on 0.9.2 also
> a_schiro@yahoo.com
> 

This (http://boatlifts4less.com/) page does not have anything to do with this
bug. The page specifies "text-decoration: blink" for the main body of the web
page. Mozilla renders this page as designed by the author. This bug involves a
flashing because of quick refreshing of a dynamic JavaScript.

Comment 6

13 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #1)
> > > WFM: Using 0.9.2 - nothing blinks.
> > Go to http://boatlifts4less.com/ all text blinks on 0.9.2 also
> > a_schiro@yahoo.com
> > 
> This (http://boatlifts4less.com/) page does not have anything to do with this
> bug. The page specifies "text-decoration: blink" for the main body of the web
> page. Mozilla renders this page as designed by the author. This bug involves a
> flashing because of quick refreshing of a dynamic JavaScript.


I understand that it is a bug involving the dynamic Javascript (that was my 
original thought in my bug report).  What do we do about it?  Is there going to 
be a fix for this put into Firefox 0.8?  

Comment 7

13 years ago
(In reply to comment #1)
> WFM: Using 0.9.2 - nothing blinks.

I have just installed 0.9.2 and if you wait about 5 seconds, it does start to blink.
Probably related to bug 170702.
Depends on: 170702

Comment 9

13 years ago
Confirming - Using mozilla trunk build 2004101904 on win-xp pro sp1
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Browser
Version: unspecified → Trunk

Comment 10

13 years ago
URL WFM using Mozilla 2004121004 Nightly on Windows XP.
I can see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050119 Firefox/1.0+
But I can't see it anymore, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050120 Firefox/1.0+

I bet this was fixed by the fix for bug 244366. I'm marking this fixed (and the
related bug) in a day or so, unless someone still sees the bug.
Depends on: 244366
Matic, want some advice?  Leaving layout bugs assigned to Blake is a good way to
make sure they never get looked at... ;)
Assignee: firefox → nobody
QA Contact: general → layout
No objections apparently, so marking fixed because of the fix for bug 244366.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 251867 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.