Closed Bug 251404 Opened 16 years ago Closed 16 years ago

view source translates raw non-breaking space chars into plain spaces

Categories

(Core Graveyard :: View Source, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 218277

People

(Reporter: jon, Assigned: mrbkap)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1

Unencoded non-breaking space characters display properly in the browser.
However, they are converted into plain spaces in View Source. You can test this
by viewing the source of the example page attached, saving it, and viewing it
again in the browser. The formatting will be wrong. Alternatively you can view
the source in an editor that shows invisibles. Also present in Mozilla 1.7/Mac.
I suspect it is present on all platforms.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
Unencoded non-breaking spaces should remain intact when viewing the source.
Maybe you should post your source code and explain more exactly what you
expected to happen, because Mozilla/PC and IE6/PC are showing the exact same
thing when you view source.
Assignee: bugs → doronr
Component: View Source → ViewSource
Product: Firefox → Browser
QA Contact: firefox.view-source
Version: unspecified → 1.7 Branch
Example source attached.

Even after this bug is fixed the results of View Source will "look" the same
because whitespace characters are invisible. It is a bug because what the
browser renders isn't what it presents in View Source.
This bug appears to be fixed in latest Firefox.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040928
Firefox/0.10
(In reply to comment #3)
> This bug appears to be fixed in latest Firefox.
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20040928
> Firefox/0.10

No, I was wrong - my apologies. This bug still shows up. If you cut and paste
the source from the example you will still find that the non-breaking space
characters are converted to plain spaces.
This should be a dupe of a more general "View Source shouldn't translate raw
characters" bug, except that I didn't see anything like that in the bug list.
Assignee: doronr → mrbkap
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr
Hardware: Macintosh → All
Summary: Unencoded non-breaking space characters are translated into plain spaces in view source. → view source translates raw non-breaking space chars into plain spaces
Version: 1.7 Branch → Trunk
Might this be a duplicate (or at least a consequence) of bug 194498?
Product: Browser → Seamonkey
Yes, I'm quite sure this bug will be solved when bug 194498 is solved.

*** This bug has been marked as a duplicate of 218277 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.