Implement gaussian blur (filter effect) for svg and text-shadow

RESOLVED DUPLICATE of bug 301234

Status

--
enhancement
RESOLVED DUPLICATE of bug 301234
15 years ago
10 years ago

People

(Reporter: CaptainN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040714
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040714

Implement gaussian blur (filter effect) for svg and text-shadow.

Currently there is no way to blur things in Mozilla, but upcoming features
require this functionality, like text-shadow css, and SVG's gaussian filter.

For testing an internal css style name "-moz-blur" could be implemented.

I think for SVG support this feature would rely on Bug 63335.

Bug 10713 would rely on this feature.

Reproducible: Always
Steps to Reproduce:
1. Feature request, view the samples in an svg enabled Mozilla build
2. See that they are not "Blurry"
3. the w3schools link does not work in Mozilla because the server is sending the
wrong header for svg files (but it does in IE with Adobe's SVG Viewer plugin).
Actual Results:  
Missing Blur filter

Expected Results:  
Should apply blur filter to object.
(Reporter)

Comment 1

15 years ago
Created attachment 153175 [details]
This is the svg file from the w3schools link
(Reporter)

Comment 2

15 years ago
Comment on attachment 153175 [details]
This is the svg file from the w3schools link

It doesn't seem to work in Mozilla.
(Reporter)

Comment 3

15 years ago
Created attachment 153177 [details]
This is the svg file from the w3schools link (fixed for Mozilla)

I just opened it in Illustrator, and resaved it, so now it works in Mozilla.

Comment 4

15 years ago
I believe IE uses DirectX for filters.  Maybe we should add our own set of
filters.  ImageMagick might be a good resource for that.  They have an
Apache-style license.
Assignee: general → general
Status: UNCONFIRMED → NEW
Component: Browser-General → GFX
Ever confirmed: true
OS: Windows XP → All
QA Contact: general → ian
Hardware: PC → All

Comment 5

14 years ago
May be a solution if we use the gimp core functionality through a xpcom
object... Then we will be able to implement more than this filter with a little
work. ( I do not know if the license of gimp is compatible with mpl, but I think
that it will not be a problem... )

Comment 6

13 years ago
I think, this bug is RESOLVED within

https://bugzilla.mozilla.org/show_bug.cgi?id=301234

by my opinion.
(Reporter)

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 301234 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 8

13 years ago
This was implemented for SVG, but did it fix text-shadow?  If not, this bug
isn't fixed, is it?

Comment 9

13 years ago
(In reply to comment #8)
> This was implemented for SVG, but did it fix text-shadow?  If not, this bug
> isn't fixed, is it?

I think this bug is also duplicate of bug 10713. so this bug is RESOLVED.
(Reporter)

Comment 10

13 years ago
(In reply to comment #8)
> This was implemented for SVG, but did it fix text-shadow?  If not, this bug
> isn't fixed, is it?

Oh yeah, I didn't think of that :-) - reopened.


(In reply to comment #9)
> > This was implemented for SVG, but did it fix text-shadow?  If not, this bug
> > isn't fixed, is it?
> 
> I think this bug is also duplicate of bug 10713. so this bug is RESOLVED.

This isn't necessarily a dupe of bug 10713, because as is pointed out in Comment
#65 of that bug (https://bugzilla.mozilla.org/show_bug.cgi?id=10713#c65) the
gausian filtering is optional according to the standard (though now that it has
been implemented in SVG, I don't see why they can't use that work to make it
work for text shadow too).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 11

11 years ago
Created attachment 310624 [details]
Gaussian blur on text element

Comment 12

11 years ago
I added an attachment with a non-working testcase. The dropshadow implemented
using a gaussian blur filter works fine, however the blurred text seems to be
clipped. Works fine in Opera. 

Comment 13

11 years ago
I added an attachment with a non-working testcase. The dropshadow implemented
using a gaussian blur filter works fine, however the blurred text seems to be
clipped. Works fine in Opera. Tested in Firefox 3 Beta 4. 
This bug should be marked fixed, and should have been marked as two separate bugs (both of which are dups) long ago when it was filed. The problem in comment 11 has to do with the filter region:

http://www.w3.org/TR/SVG/filters.html#FilterEffectsRegion

which I'm guessing either Opera or FF fills incorrectly, but which is a different bug.
(Reporter)

Comment 15

10 years ago
I'm not sure why this was reopened. It's done.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301234
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.