Table layout not correct after inserting row/column when colspan=0 or rowspan=0

VERIFIED FIXED in M14

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: cmanske, Assigned: karnaze)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Load the test file into Composer
For colspan test:
1. Put caret in "Cell 2"
2. Execute menu command: Table|Insert|Column before
A new columns is inserted, but the cell 4, with colspan=0, should now extend
one more cell to the end of the table.

For rowspan test:
1. Put caret in "Cell 6"
2. Execute Table|Insert|Row below
A new row is inserted, but cell 5, with rowspan=0, should now extend one more
cell downward to the end of the table.
(Reporter)

Comment 1

19 years ago
Created attachment 4589 [details]
Test table with colspan=0 and rowspan=0 cells
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 2

19 years ago
Charlie, get my checkins from this evening and tell me if the 1st problem is 
solved. I'm not sure what the editor is doing when it inserts a column.

Also, in the 2nd problem, nsHTMLEditor::InsertTableRow gets into an infinite 
loop because it is calling GetCellDataAt with the same row and col indices.
Assignee: karnaze → cmanske
Status: ASSIGNED → NEW
(Reporter)

Comment 3

19 years ago
Created attachment 4801 [details]
The CORRECT table to test this bug
(Reporter)

Comment 4

19 years ago
Sorry, the table supplied was not the correct one.
The problem seems fixed for the COLSPAN=0 case.
Use the new table to test the ROWSPAN=0 case -- that problem still occurs.
I'll look into the infinite loop problem -- thanks for finding it!
Assignee: cmanske → karnaze
(Assignee)

Comment 5

19 years ago
Fixed with latest checkin.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Fixed in the Feb 22 build.
You need to log in before you can comment on or make changes to this bug.