[quirks] document.close() required before window will finish loading and load images

RESOLVED DUPLICATE of bug 81980

Status

()

defect
RESOLVED DUPLICATE of bug 81980
15 years ago
4 months ago

People

(Reporter: sylvain.graveron, Unassigned)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

go to http://www.lacentrale.fr/index.php
Exemple : 
Select Département seul => 92
select "Par marque" => Mitsubishi select "Energie" => Diesel
Clic "Voir les Annonces"
Clic on a "camera" to see photo and clic on the car's photo.
New Windows open but BLANK.
If I try with IE6 it's OK !


Reproducible: Always
Steps to Reproduce:
go to http://www.lacentrale.fr/index.php
Exemple : 
Select Département seul => 92
select "Par marque" => Mitsubishi select "Energie" => Diesel
Clic "Voir les Annonces"
Clic on a "camera" to see photo and clic on the car's photo.
New Windows open but BLANK.
If I try with IE6 it's OK !

Actual Results:  
Nothing

Expected Results:  
Nothing

Nothing

Comment 1

15 years ago
This is a better start page
http://www.lacentrale.fr/recherche_auto.php

I see the same thing. It opens a window, but the window never loads the image
(or finishes loading itself).
Confirm that IE6.0 works... 

A simple test case confirms that Mozilla never finishes loading the page, even
if it is just text, and never loads images.

<p>Hi. Click on this: <a href="#" onClick="showPhoto('<p>Bok</p>')">blogmungous</a>

<script language="JavaScript">
function showPhoto(photo) {

var photo;
newWindow = window.open('');
newWindow.document.write(photo);
}
</script>

The only question in my mind, is there any reason why this might be the CORRECT
behaviour (by the ECMA standard)?

Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Summary: No link open with FireFox => Ok with IE6 → New window from Javascript never finishes loading

Comment 2

15 years ago
Ah! See bug 98530.
The answer there was that the page author should make it call document.close(),
and indeed, that fixes my test case.
IE is more forgiving in this case.

Also note that in their code, they have not quoted the img URL. However Mozilla
lets this slide.

So is this something for quirks mode?

Comment 3

15 years ago
Change to DOM, mark quirks
Component: Layout: Images → DOM
Summary: New window from Javascript never finishes loading → [quirks] document.close() required before window will finish loading and load images
Assignee: jdunn → general
QA Contact: core.layout.images → ian
Reporter

Updated

15 years ago
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
Er ... no this is not fixed. 
Unless quirks mode is going away.
Reporter

Updated

15 years ago
Status: RESOLVED → VERIFIED
REOPEN, nothing in Mozilla was fixed here.
Status: VERIFIED → REOPENED
Keywords: qawanted
Resolution: FIXED → ---

Comment 6

15 years ago
*** Bug 263977 has been marked as a duplicate of this bug. ***
Assignee: general → nobody
QA Contact: ian → general
This looks like a duplicate of bug 81980 – document.open()/document.write() without document.close() does not stop throbber and trigger repaint
Status: REOPENED → RESOLVED
Closed: 15 years ago6 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 81980
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.