In a nested frameset written by JavaScript's document.write, the progress indicator will run perpetually

RESOLVED DUPLICATE of bug 143398

Status

()

Core
Layout: HTML Frames
RESOLVED DUPLICATE of bug 143398
14 years ago
14 years ago

People

(Reporter: Jon Sablatnig, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

The page (index.html) is a frameset that opens another frameset (frame.html).
The second frameset opens a page, but rewrites the document via JavaScript's
document.write method (with the same content as before, btw).  The page is
shown correctly, but the progress indicator on the top right will run continuously
forever.  Similarly, the status line indicates the browser is somehow waiting
for the host.

Reproducible: Always
Steps to Reproduce:
Open the webpage http://tempel.math.tu-berlin.de/~jon/bugzilla/

Actual Results:  
The page is shown (correctly), but the progress indicator will not stop running.

Expected Results:  
Show the page and stop turning the progress indicator.

Note that if one removes the onload="rewrite()" in frame.html, everything works
as expected, although the webpage still has the exact same content as before.

Also note that if the content does NOT load an image, the problem does NOT occur.

This bug has been around since at least Mozilla 1.3, and is still existant in
1.7.
Assignee: general → nobody
Component: JavaScript Engine → Layout: HTML Frames
QA Contact: pschwartau → core.layout.html-frames

*** This bug has been marked as a duplicate of 143398 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.