Crashes every time I try to access the posted URL.

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: revo, Assigned: Alfred Peng)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Firefox crashes every time I access the following site:
http://www.nic-las.com/enzyklopaedie/documents_search_engine/developwalter_20benjamin.asp
The page starts to load and then, at some point, it closes all windows and tabs.
It just "disappears". I can't identify which object on the URL makes it crash.

Reproducible: Always
Steps to Reproduce:
1. load
http://www.nic-las.com/enzyklopaedie/documents_search_engine/developwalter_20benjamin.asp
2. see it crash
3.
(Reporter)

Comment 1

13 years ago
Additional information:
When I launch firefox from a terminal, I get the following output when it crashes:

revo@hal:~$ /opt/firefox-0.9.1/firefox
Warning: Cannot convert string
"-b&h-lucida-medium-r-normal-sans-*-140-*-*-p-*-iso8859-1" to type FontStruct
INTERNAL ERROR on Browser End: Plugin instance index out of bounds 25705

System error?:: Resource temporarily unavailable
revo@hal:~$

If you need some more information, just contact me.

Comment 2

13 years ago
revo: Could you provide TalkBack incident ID?
Keywords: crash
(Reporter)

Comment 3

13 years ago
Sorry, didn't read the BugWriting guidelines carefully enough...
Here it is: TB350831M.
Is this a correct Talkback? I never used this before...
Anyway, as I had to download a build which is talkback-enabled, I can provide
you with some more information:
The crash only occurs, when I have the libjavaplugin_oji.so in the plugin-dir.
When I access the page without it, firefox doesn't crash, it just wants to
download the plugin.
Maybe this helps.

Comment 4

13 years ago
TB350831M is what I want, but this one is nearly blank. What version of Java
plugin do you have?
(Reporter)

Comment 5

13 years ago
It is the plugin from precompiled j2sdk-1.4.2 package by sun. The plugin should
be the version compiled with gcc-3.x

Comment 6

13 years ago
Could not reproduce the bug (OS X 10.3.5, Firefox 1.0, Java 1.4.2). Page loads
fine here.

Comment 7

13 years ago
(In reply to comment #0)

I was just about to create a new bug when I came across this which appears
to be related to my problem. Similar result, different site:

Version: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20041223
Firefox/1.0+

OS: Red Hat Linux 3.2.2-10 (aka RH 9.0 Pro)

Reproduceable: Always

Expected result: page loads

Actual result: browser exits

Steps to reproduce:
  1. load http://www.rotoaction.com
  2. browser exits
  3. shell where browser started contains the following output:
*** nsExtensionManager::_disableObsoleteExtensions - failure, catching exception
so finalize window can close
*** loading the extensions datasource
*** loading the extensions datasource
INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
INTERNAL ERROR on Browser End: Could not read ack from child process
System error?:: No such file or directory

I used libjavaplugin_oji.so from Sun (j2re1.4.2_06/plugin/i386/ns610-gcc32/lib).
Removing the plugin asked me to download the plugin but it did not crash.

This did not crash in Mozilla 1.2.1, but I also did not attempt to 
enable java applets with Mozilla 1.2.1.

Comment 8

13 years ago
andyw@bondmart.com: your problem sounds like you copied the plugin to your
plugins directory (in direct contradiction to the installation directions and
the faq and whatever other documentation there is). but just because a message
says "INTERNAL ERROR on Browser End" does not mean it's the same problem, in
fact its the tail that distinguishes the problems ...
Assignee: firefox → kyle.yuan
Component: General → Java: OJI
Product: Firefox → Core
QA Contact: firefox.general
Version: unspecified → Trunk

Comment 9

13 years ago
revo <dalas@web.de>: Could you still reproduce this crash with Firefox 1.0.2 or
actual nightbuild?

Updated

12 years ago
Assignee: yuanyi21 → pete.zha

Comment 10

12 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng
(Assignee)

Comment 11

12 years ago
Revo, the link you provided is out of date. Could you give us another one?

Andy, your testcase can load correctly here on Solaris, with Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.0.1) Gecko/20060206 Firefox/1.5.0.1 and Java(TM) Plug-in 1.5.0_06-b05.

Could anyone reproduce the crash?
(Assignee)

Comment 12

12 years ago
It also can't reproduced on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1 here and Java(TM) Plug-in 1.5.0_05-b05.

Comment 13

10 years ago
The URL gives a 404. Bug should probably be closed.

Comment 14

10 years ago
WebArchive has these entries:
http://web.archive.org/web/*/http%3A//www.nic-las.com/enzyklopaedie/documents_search_engine/developwalter_20benjamin.asp
and all redirects to:
http://www.nic-las.com/enzyklopaedie/show.asp?diff=nxref&nxref=walter%20benjamin&area=develop

Is anybody able to reproduce crash on new URL?

Comment 15

9 years ago
Running on:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Java(TM) Plug-in 1.5.0_16-b02
on Scientific Linux:

I am unable to reproduce a problem with the above URLs.
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.