Linux and Mac should offer option to import Saved Passwords same as windows

RESOLVED WONTFIX

Status

()

Firefox
Migration
RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: tracy, Unassigned)

Tracking

1.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrunner, URL)

(Reporter)

Description

14 years ago
Linux and Mac do not offer to import Saved Passwords for Mozilla/NS6/NS7
migrations.  Windows does offer this option.
(Reporter)

Comment 1

14 years ago
testrunner test case linked in URL above
Whiteboard: testrunner

Comment 2

14 years ago
0.9.3 does offer you this option, but it seems broken. when i try to import
passwords from a mozilla profile, the password list is empty, even the previous
entries are gone.

Steps to reproduce:

File->Import->Mozilla->[profile]->select passwords->finish

Result:
  List empty

Keywords: dataloss

Expected:
  Many entries

Comment 3

14 years ago
This options still seems to be broken in 1.0PR on Mac OS X. Tried to import
passwords from Mozilla 1.8a4, the dialog does "something", but no password are
imported it doesn't make a difference if a master pwd is set in Mozilla or not).

Is there a way to manually transfer the passwords?
Assignee: bugs → nobody
That's a long and outstanding bug but still present when trying to import profile data from Safari. I think we better should separate the implementation for Linux and OS X.

Tracy, which OS shall this bug cover?
(Reporter)

Comment 5

10 years ago
Why separate them?
The UI will be the same that's true, but the back-end code is totally different. You can see the same with bug 355538 which shows that this feature doesn't even work anymore for IE7.
we won't offer migration from Netscape 6 and likely 7, sorry!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.