Some CSS rules ignored for absolutely positioned children of small absolutely positioned elements

VERIFIED DUPLICATE of bug 201897

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 201897
14 years ago
14 years ago

People

(Reporter: Wolfgang Schwarz, Assigned: dbaron)

Tracking

({testcase})

Trunk
Other
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Here is an absolutely positioned element which is the only child of another
absolutely positioned element:

<div style="position:absolute; left:500px; top:10px; border:1px solid red;">
<div style="position:absolute; left:0px; top:100px; background-color:yellow;
text-align:center; color:blue;">
line 1 blabla<br>
line 2
</div>
</div>

I would expect the style rules for the inner div to apply, but the text isn't
centered and the background isn't yellow. The positioning and font colour is
correct though.

If the outer div is assigned a sufficiently large width, the problem disappears.
Also, if the inner div has a negative x position, the part of it located in the
negative area is yellow. 

I'm seeing this on Linux in Firefox 0.9.1, SeaMonkey 1.7, and the 04-07-12
nightly from the Seamonkey trunk. 

I'm leaving this as unconfirmed because I'm not a CSS expert and so not sure
this is actually a bug. FWIW, Konqueror and Opera show the expected behaviour.
(Reporter)

Comment 1

14 years ago
Created attachment 153434 [details]
testcase (with inner div left:-10px)

*** This bug has been marked as a duplicate of 201897 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
Keywords: testcase
You need to log in before you can comment on or make changes to this bug.