Closed Bug 251815 Opened 16 years ago Closed 16 years ago

SAVE AS webpage, complete changes name of style file

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows 98
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 115107

People

(Reporter: ve3ll, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040715
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a3) Gecko/20040715

the style.css file is saved but renamed as style.txt and
the link modified to point at style.txt
in addition a background file referenced in the style file
IS NOT saved at all. Thus the view using a local copy is
DIFFERENT from the server view. Shouldn't all files needed
to duplicate the view be saved, whether referenced directly
in the page or indirectly thru the stylesheet which is referenced
from the page ????  otherwise webpage, complete is a misnomer...

Reproducible: Always
Steps to Reproduce:
1. view the stated url
2. save as webpage complete
3. view the local copy

Actual Results:  
the menu sidebar loses its background image

Expected Results:  
saved the background and modified the reference accordingly
Warning: The stylesheet http://home.cogeco.ca/~nursingprocess/style.css was
loaded as CSS even though its MIME type, "text/plain", is not "text/css".

The site is saying the CSS file is plain text, that's most likely why.

This WFM on many other sites.
Assignee: general → file-handling
Component: Browser-General → File Handling
QA Contact: general → ian
I didn´t do a save as, just looked at Page Info:

http://home.cogeco.ca/~nursingprocess/style.css
is served as Type: text/plain

compare with bugzilla´s stylesheet

http://bugzilla.mozilla.org/css/edit_bug.css
is served as Type: text/css

Seems to me that bug is either TechEvangelism or Invalid.
> in addition a background file referenced in the style file IS NOT saved at all.

This is bug 115107.

The renaming issue doesn't affect display, as you noted, so it's not an issue at
all for "save complete" purposes.

Marking duplicate.

*** This bug has been marked as a duplicate of 115107 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.