convert MAPI code to use 'W' APIs

RESOLVED DUPLICATE of bug 1048658

Status

defect
RESOLVED DUPLICATE of bug 1048658
15 years ago
4 months ago

People

(Reporter: jshin1987, Assigned: smontagu)

Tracking

({intl})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

15 years ago
When bug 239279 is resolved, we have to convert mailnews/mapi to use 'W' APIs.
Reporter

Comment 1

15 years ago
To test 'MZLU' (bug 239279), I made a patch for mailnews/mapi/mapihook/src
Product: MailNews → Core

Updated

14 years ago
Summary: convert MAPI code to use 'W' APIs → convert MAPI code to use 'W' APIs
Reporter

Comment 2

13 years ago
(In reply to comment #1)
> Created an attachment (id=155474) [edit]
> mapihook patch

Now that we dropped support for Win 9x/ME, this patch doesn't need MZLU. I haven't finished converting to 'W' APIs completely, though.
Status: NEW → ASSIGNED

Updated

11 years ago
Assignee: jshin1987 → smontagu
Status: ASSIGNED → NEW
QA Contact: simple-mapi
Product: Core → MailNews Core

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048658

Comment 4

4 months ago

I'm sorry, but this is not a dupe for bug 1048658. The latter is about implementing a MAPI W-function TB didn't support; while this one is about TB code using W APIs (e.g., CreateFileW [1] for file access).

No idea how relevant it is currently, but the two tasks are completely different.

[1] https://docs.microsoft.com/en-us/windows/desktop/api/fileapi/nf-fileapi-createfilew

You need to log in before you can comment on or make changes to this bug.