Line containing multiple links does not wrap around - goes off page

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: INVALID?, )

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

The line of links on the top of the page at www.edwardgoldsmith.com does not
wrap around. This page has been verified HTML compliant. It does wrap around on IEX.

Reproducible: Always
Steps to Reproduce:
1. just bring the page up
2.
3.
Those links specify nowrap.  The whitespace around the "|" is   which is
not supposed to wrap.  Therefore the browser has no location it is allowed to
wrap around, so IE is behaving incorrectly.

Comment 2

15 years ago
This only happens in quirks mode.  Changing the DTD to 4.0 Strict shows the
desired layout
Assignee: general → nobody
Component: Browser-General → Layout
QA Contact: general → core.layout
I believe this is a dupe of 95067, based on the rules here:
http://www.unicode.org/unicode/reports/tr14/
Component: Layout → Browser-General
Reporter

Comment 4

15 years ago
Having submitted this bug, I'm no longer sure it is one after reading comments -
at least not in the way I originally thought. Perhaps more a case of
over-faithful  rendering. I have now changed the separator string between the
keywords in the header to "&nbsp | &nbsp" and now it wraps the line as intended. 

Oliver Tickell.
Product: Browser → Seamonkey
Component: General → Layout
Keywords: qawanted
Product: Mozilla Application Suite → Core
Whiteboard: INVALID?
Reporter

Comment 5

14 years ago
The bug is actually slightly different to how originally described - having 
carried out the corrections suggested by comment #1, another problem has 
emerged: the line does wrap around, however it does so too 'late' so that the 
line overspills the right margin of its 'container'.

Oliver Tickell.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 7

13 years ago
Both www.tfx.org.uk and www.edwardgoldsmith.com share a similar design and don't show non-breaking menus or text overlap when resized in bonech/minefield from today. -> WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.