Closed Bug 252124 Opened 18 years ago Closed 17 years ago

bookmarks menu should remain open when a user selectes "New <foo>", cut, copy, paste, delete

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 195031

People

(Reporter: asa, Unassigned)

References

Details

The bookmarks menu should remain open after the user creates a new bookmark, new
folder, or new separator via the context menu. The current behavior with Firefox
on Windows is that as soon as you select that new<foo> item from the context menu.
Flags: blocking-aviary1.0?
The bookmarks menu should also stay open when deleting bookmarks via the context
menu, in my opinion. At the moment it can be frustrating trying to delete a
couple of bookmarks in the same sub-sub-folder.
This is pretty much impossible to do -- bookmarks has no control over the menu;
the menu closes itself after the command executes.

Maybe we should just get rid of the New.. entries in the bookmarks menu, for the
problem that is mentioned here, as well as because it's not clear at all where
the "new" thing will go?  Right-clicking on a bookmark and getting "New *"
entries makes no sense -- the "New *" bits aren't 'context' in any way for the
bookmark itself.  Right-clicking on a folder and selecting New * makes some sort
of sense, in that it gets created inside that folder -- but there's no way to
right-click the toplevel Bookmarks container from the menu, so we lose again.

If someone wants to create a new folder/bookmark/separator, they could do so
much more comfortably from the sidebar or the manager...
that goes against a lot of the "change stuff where you use it" UI we've been
working on (i.e. right-click to customize toolbars, direct access to add search
engines, etc).

They're context for the location of the bookmark, which is admittedly tenuous
logic, but it works. :)
Please change the summary of this bug to expand the scope to include the varied
complaints in the previous comments.

The bookmarks menu should remain open when a user selectes "New <foo>", cut,
copy, paste, or delete.
Summary: bookmarks menu should remain open after creating new items via the context menu → bookmarks menu should remain open when a user selectes "New <foo>", cut, copy, paste, delete
vlad says too dangerous for this late in the game. 
Flags: blocking-aviary1.0? → blocking-aviary1.0-
*** Bug 270265 has been marked as a duplicate of this bug. ***
Assignee: vladimir → vladimir+bm
Duping to the better known bug.

*** This bug has been marked as a duplicate of 195031 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
*** Bug 299614 has been marked as a duplicate of this bug. ***
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.