XML Parsing Error when launching Help

RESOLVED WORKSFORME

Status

SeaMonkey
Help Viewer
--
major
RESOLVED WORKSFORME
14 years ago
2 years ago

People

(Reporter: Bill Mason, Assigned: R.J. Keller)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040718 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3) Gecko/20040718 Firefox/0.9.1+

XML Parsing Error: xml processing instruction not at start of external entity
Location: chrome://help/content/help.xul
Line Number 1, Column 1:


^

Reproducible: Always
Steps to Reproduce:
1. Help -> Help Contents



Seen on the trunk.  Not tested on a branch build.
(Reporter)

Updated

14 years ago
Version: unspecified → Trunk
Also getting errors on branch with this build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040719
Firefox/0.9.1+

When selecting different topics from help->contents
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0?
(Assignee)

Comment 2

14 years ago
I cannot reproduce this bug on the trunk or the aviary branch. I'm running
20040718 nightly builds on the trunk and aviary branch (currently the latest on
the FTP servers). Both launch Help with no errors.
Flags: blocking-aviary1.0?
The latest Aviary is 20040719 and this is the version that I had trouble with. 
The error does not come on launch.  If you go to help contents, some of the
choices in the left pane cause the errors.

Selecting "Using Mozilla Firefox" results in:

</body>
--^

Selecting "Customization" results in:

 Themes<span> menu item.</p>
---------------------------^
(Assignee)

Comment 4

14 years ago
wgianopoulos: This bug is about XML parsing errors in Help itself, not the
documents. But thanks for the documents errors. I fixed those. Should be in
tomorrows nightly builds.

It's the errors in Help itself that I cannot reproduce.

Reporter: Can you post a screenshot?
Flags: blocking-aviary1.0RC1?
(Reporter)

Comment 5

14 years ago
Created attachment 153711 [details]
Error window screenshot

There's apparently something funny on my setup, as I did a reinstall of this
build with a new profile and now I don't even have Help Contents on my Help
menu.

If I put the chrome URL into the URL bar directly, I can still reproduce that
error message.

I don't know if "Help Contents" going missing now is a bug or not, since I'm
not sure of the state of Help on the trunk.  But maybe this bug is invalid.

Comment 6

14 years ago
I can't reproduce comment 0 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a3) Gecko/20040719 Firefox/0.9.1+. Comments 1 and 3 are already fixed.

I had the problem with a missing Help Contents menuitem as well. Deleting
dist/bin/chrome and "make chrome" in mozilla/ solved it for me.
(Assignee)

Comment 7

14 years ago
Bill Mason: I think you're having a problem on your end. Might want to try
reproducing this with a fresh Firefox nightly build and a new profile.
(Reporter)

Comment 8

14 years ago
(In reply to comment #7)
> Bill Mason: I think you're having a problem on your end. Might want to try
> reproducing this with a fresh Firefox nightly build and a new profile.

I did already.  That got me the results in comment 5.
(Assignee)

Comment 9

14 years ago
I'm going to have to resolve this as WORKSFORME. If someone other than the
reporter can reproduce this bug in the latest AVIARY branch build, reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Component: Help Viewer → Help Viewer
Product: Firefox → Toolkit
Version: Trunk → unspecified
Product: Toolkit → Seamonkey
You need to log in before you can comment on or make changes to this bug.