Closed Bug 252295 Opened 19 years ago Closed 19 years ago

unable to edit saved searches

Categories

(Bugzilla :: Query/Bug List, defect)

2.17.6
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: altlist, Assigned: justdave)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040626 Firefox/0.8

When editing a named query, it does not include the "query_format" attribute in
the URL line.  Net result, you see the "specific" page rather than the "advanced"
page, thereby losing the ability to edit your searches.

I believe checksetup.pl now needs to scan all namedqueries and insert the
query_format attribute wherever it is not specified.  

In my case, the query_format attributes are all set to blank/default.  Found
this when I upgraded from 2.17.7 to 2.18RC1

This

Reproducible: Always
Steps to Reproduce:
Summary: edit saved search is missing query_format=advanced → unable to edit saved searches
Attached patch suggested 2.18rc1 patch (obsolete) — Splinter Review
This is what I ended up doing to clean up the pre-2.18 named queries
Gerv,

any opinion on this?
I would have thought we could detect that we are editing a named query and
automatically fiddle the format parameter, rather than having to update
everyone's stored queries, bookmarks etc.

Switching the default was a bad plan. We should have just changed the links in
other bits of Bugzilla to specify the other format.

Gerv
Tested on landfill...  this affects all queries that were saved before we
created the "Find a specific bug" search, and some queries saved before we
introduced the changeable default.

Any query that was saved after the changeable default was introduced will be
okay.  Any query created from the format=specific page will be okay.  Queries
created from the advanced page prior to the changeable default are not okay.

The obvious answer is to add query_format=advanced to any saved query that
doesn't have a query_format parameter in it.  Since this is the only case that
fails, we should be able to do this at runtime when the query is loaded for
editing, instead of doing an invasive edit via checksetup.pl.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking2.18+
Target Milestone: --- → Bugzilla 2.18
Version: unspecified → 2.17.6
> The obvious answer is to add query_format=advanced to any saved query that
> doesn't have a query_format parameter in it.

Does that work for bookmarks as well as ?

And is it too late to instead implement the correct fix, in the second paragraph
of comment #3? :-)

Gerv
Attached patch Patch v2Splinter Review
Attachment #153820 - Attachment is obsolete: true
(In reply to comment #5)
> > The obvious answer is to add query_format=advanced to any saved query that
> > doesn't have a query_format parameter in it.
> 
> Does that work for bookmarks as well as ?

Yes, in fact. :)  (Note that I also said I planned to do it when loading the
query - see the patch I just attached)

> And is it too late to instead implement the correct fix, in the second
> paragraph of comment #3? :-)

Yes, because that would be a real mess of code to try to read their cookie to
figure out which query page to send them to.  :)
Attachment #158559 - Flags: review?(gerv)
Whiteboard: patch awaiting review
Comment on attachment 158559 [details] [diff] [review]
Patch v2

Seems a bit inefficient to regenerate the entire buffer, but I guess it'll
work. Looks good to me (one nit: it needs a space between 'query_format', and
'advanced').

Gerv
Attachment #158559 - Flags: review?(gerv) → review+
Flags: approval2.18?
Whiteboard: patch awaiting review → patch awaiting approval
(In reply to comment #8)
> (From update of attachment 158559 [details] [diff] [review])
> Seems a bit inefficient to regenerate the entire buffer

I agree.  That should be able to go away when we stop using $::buffer (which
needs to happen for mod_perl).

A better way to do that would probably be to make it feed $params->query_string
to urlquerypart in vars instead of $::buffer, but that'd have to be done when we
get rid of $::buffer :)

> (one nit: it needs a space between 'query_format', and 'advanced').

fixed this on checkin.

Trunk:

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.262; previous revision: 1.261
done

2.18 branch:

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.255.2.3; previous revision: 1.255.2.2
done
Status: NEW → RESOLVED
Closed: 19 years ago
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+
Resolution: --- → FIXED
Whiteboard: patch awaiting approval
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.