All users were logged out of Bugzilla on October 13th, 2018

{inc}Table grows when the mouse hover's over some text and the font changes in a div tag

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: gspiers, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

As I move the mouse of the text the font changes (because of a css hover) and it
resizes the table.  This only happens when the div tag is set to 100%.
The example from the webpage is minimal but it does make a large effect when
there  is a lot of information on the page.

This seems to only occur in firefox 0.9.  It does not happen in 0.8

Reproducible: Always
Steps to Reproduce:
1. Go to http://136.159.14.48/grow.html
2. Move mouse back and forth over the text
3. Watch the table grow

Actual Results:  
The table grows.

Expected Results:  
The table should not continue to resize and shouldn't continue to get bigger.

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk
Please attach the testcase to the bug using
http://bugzilla.mozilla.org/attachment.cgi?bugid=252350&action=enter so it won't
disappear.
Whiteboard: DUPEME

Comment 2

14 years ago
I´m seeing some similarities to 
Bug 252200 clicking the submit button causes the entire form's layout to resize
... makes it wider, breaks visual page layout.

That bug regressed between wfm BuildID 2004052921 and regressed 2004060217.

Comment 3

14 years ago
Created attachment 153844 [details]
even more minimalized testcase

changing border from 1 to 10 gives more growth than in the original testcase,
removing 'overflow: auto' from the DIV removes bug.
grows two times: on mouseover, and on mouseout.

Comment 4

14 years ago
though I see similarities, this bug is regressed using BuildID 2004052921, and
Bug 25200 is wfm running in another tab.
Summary: Table grows when the mouse hover's over some text and the font changes in a div tag → {inc}Table grows when the mouse hover's over some text and the font changes in a div tag
(Reporter)

Comment 5

14 years ago
Created attachment 153862 [details]
Testcase

Comment 6

14 years ago
bug not seen in Mozilla 1.6
seen in Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040203 and later.
This doesn't happen in:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040202
But it does happen in:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040203
(the same observation as comment 6)

I believe this bug is caused by fixing bug 232754. 
I backed out that patch and recompiled my build -> the testcases didn't 'grow'
on hovering anymore (although the behavior without that patch is certainly not
right either)
Depends on: 247487

Comment 8

14 years ago
Created attachment 155473 [details]
Font weight test case

In addition to changing the actual font, simply changing the font weight gives
the same affect.
All the testcase don't grow anymore on hover, but now they shrink to a certain
size, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; @AB_CD@; rv:1.8a4) Gecko/20040924
Firefox/0.9.1+ 

Comment 10

14 years ago
overflow auto: causes a XUL-frame (the scrolled frame) creation.  

XUL frame reflow sucks. 

Before we relied that XUL frames lied about the MEW, now they dont lie anymore
so we see that the can not compute the maximumWidth. Robert is working on a
patch to ban them completely from html reflow.
Depends on: 240276
No longer depends on: 247487

Updated

14 years ago
Keywords: testcase
The patch in bug 276286 fixes the first and third testcases here, but not the
second one (at least not completely).
Depends on: 276286
I can also still see a minor problem with the first and third testcase in the
2005-10-10 build.
After I hovered over the link, the gray bordered box is somewhat bigger than before.
These testcases are a little weird; width:100% is trying to set the
content-width of the cell contents to the full width of the cell, which is not
possible given the border width. Anyway, my patch for bug 240276 at least
produces results for these testcases that are consistent over time and do not
change with incremental reflows.
Neither of the testcases grow on me, when hovering, so I'm marking this bug
WORKSFORME.
I still see an issue with the testcases though, I filed bug 293453 for that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.