mcafee.com - Improper Menu Coloring

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I'm not sure what category to file this under, so I'm leaving it as general. 
I've found this same problem in firefox on numerous sites.  For some reason,
menus aren't properly colored.  I'm not sure if this is a bug, or improper
coding on the part of the web designers.  All the same, I know it displays as
intended in IE, so I'm submitting it and leaving the judgement up to the
experts.  You'll notice in the example website, the menu along the left displays
a light blue, with only the dark blue being displayed directly behind the text.
 Rather, the entire menu is intended to be dark blue, turning light blue only
when moused-over.  Another good example is
http://www.gocyberlink.com/english/index.jsp
This page uses drop down menus.  Only the text is backed with gray, instead of
the entire dropdown menu (as in IE).  I appologize if this is the fault of the
developers instead of Moz/FireFox, but it occurs on so many websites I felt it
necessary to submit.

Reproducible: Always
Steps to Reproduce:
1.  Go to the example sites.
2.  Observe the coloring on the menus.


Actual Results:  
The menus only display the intended background color directly behind the text,
rather than for the width of the menu.

Expected Results:  
The entire menu would display the proper background color.

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → Trunk
> All the same, I know it displays as intended in IE, so I'm submitting it and
> leaving the judgement up to the experts.

Thank you for filing the bug!  This is indeed a known problem in IE's layout of
display:inline elements.  The page should be setting those <a> elements to
display:block if they want the background to extend past the text. 
Unfortunately, since it "works in IE" web developers don't do that...

> Another good example is http://www.gocyberlink.com/english/index.jsp

This is the same issue.  Please file a separate Evangelism bug on it?
Assignee: nobody → english-us
Component: Layout → English US
Product: Browser → Tech Evangelism
QA Contact: core.layout → english-us
Version: Trunk → unspecified

Updated

14 years ago
Summary: Improper Menu Coloring → mcafee.com - Improper Menu Coloring
(Reporter)

Comment 2

14 years ago
This bug appears to have been corrected! Resolving, thanks McAfee.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.