Closed Bug 252495 Opened 17 years ago Closed 17 years ago

Save As corrupts/converts HTML special characters, eg. "£"

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: kyrian, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

On a number of occasions people have reported to me that files I've created and
done a "Save As" in Mozilla under Fedora Core/RedHat have appeared corrupted
under IE.

It look like this is down to the fact that when you save a page with eg
"£" in it, the file that gets saved has these HTML special codes
translated to literal characters before saving the file, rather than preserving
the original HTML.

When doing a "View Source" on these pages, prior to a "Save As", the HTML codes
appear correctly, but once saved to a file and opened in a text editor, they
have been replaced by the raw character.

Reproducible: Always
Steps to Reproduce:
1. Find a HTML page with "£" in it.
2. "Save As..."
3. view the raw HTML file afterwards.

Actual Results:  
It's been reported to me by other people that the files have been corrupted
twice, and when I tried it myself I saw what I describe above.

Expected Results:  
It should have left the HTML special character codes as-is in the saved out file.
You're saving "Web page, complete".  That saves the DOM, not the source, and
there is no way to tell whether a character in the DOM was an actual character
or a character entity.  If the character can be represented in the page charset,
we save it as the character.  Since it can be represented in the page charset,
that works.

If you save as "HTML only" we will save the exact source the server sent.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.