Background images and scrollbars

VERIFIED FIXED in M4

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
In the above URL, the background-position puts the background image in the
upper right corner.  This image is placed correctly before the scrollbar is
drawn, but then it is not moved when the scrollbar is drawn
and a horizontal scrollbar is created to allow one to see the whole background
image.

This raises a number of interesting points:

1) In the overflow property, where do scrollbars go?  This isn't defined in
  the spec, and should probably be clarified.  The problem in the above URL
  is a good example to help think about how it should be defined.  I tend to
  think that a scrollbar should go, perhaps, in a gap between the right border
  and the right padding.  (i.e., be placed in the right padding and increase
  the padding by the width of the scrollbar)  Is this how you do it?  I'm not
  sure.  I guess I'll raise this on www-style...

2) If the above answer is adequate (and I think my suggestion is), could you
  do scrolling on the document simply by defining "HTML { overflow: auto; }"?
(Reporter)

Comment 1

19 years ago
See http://lists.w3.org/Archives/Public/www-style/1999Jan/0078.html for my post
to www-style, if you're interested.

Comment 2

19 years ago
As far as question #1 goes, yes the scrollbar is positioned in a gap between the
border and the padding

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: troy → kipp
Status: ASSIGNED → NEW

Comment 3

19 years ago
Now I see the problem. Even though it looks like we're widening the window to
make the background visible, that's not the case.

The problem is that we've partially switched over to a new approach for
calculating the CSS2 computed info, but the block/inline code (block in
particular) isn't converted yet.

Comment 4

19 years ago
Setting all current Open/Normal to M4.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
Fixed. Everything seems to be in its place.

Updated

19 years ago
QA Contact: 4110

Comment 6

19 years ago
Chrisd as QA contact
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Verified fixed.
You need to log in before you can comment on or make changes to this bug.