Closed Bug 252504 Opened 17 years ago Closed 17 years ago

Focus on a textarea is lost when another tab contains fields that autocomplete

Categories

(Toolkit :: Form Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 124750

People

(Reporter: Athropos, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040713 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040713 Firefox/0.9.1+

Well, this is a tricky bug, it happened to me while filling another bug. I
opened a tab to log in to the website of my telephony operator SFR (don't know
if this is the good term) while I was filling a bug. I switched tab (the website
is rather slow) and start typing my report when the focus was lost, exactly when
the other finished loading.
I tried a few times and was able to reproduce it each time, but only with the
website of SFR. I suppose this is linked to the autocomplete feature, because
one time Firefox managed to display a tooltip with my phone number (login id) in
the tab with bugzilla (I suppose my mouse was on the same position as the field
with my phone number in the other tab).

Reproducible: Always
Steps to Reproduce:
1. Open a page in a tab that contains a textarea (like the commit field in bugzilla)
2. Open a new tab on https://www.sfr.fr/includes/services/mon_compte/index2.jsp
3. Fill the fields with any values, but tell FF to remember them, so that the
next time autocomplete will fill them
4. Reload the tab
5. Switch to the one that contains the textarea and start typing something until
the other tab finishes loading

Actual Results:  
When the other tab is completely loaded, the focus is lost by the textarea, even
if you were typing in it

Expected Results:  
Focus should not be lost
In a discussion about the 7/21 nightly build
(http://forums.mozillazine.org/viewtopic.php?p=666146), fishbert noted this
problem, and I also had that issue.  Steps to reproduce are to go to a site with
a textarea (such as bugzilla) and have your cursor in the textarea.  Load a new
tab and go to a site that moves the cursor to a textarea onLoad (fishbert's
example was http://www.myrealbox.com).  Go back to the first tab before the
second has loaded, begin typing in the text area.  When the focus shifts for the
second tab, it takes your cursor and even will input the text as you continue to
type.  Hopefully fishbert will post some more comments as he re-discovered this
issue.
I have a similar example
I always use multimple tabs and in one have an autorefreshing page that loads
data and will sound an alarm if the data exceed a certain value.
As soon as the alarm sounds the focus is stolen from the input/textarea in the
tab i'm active in.
Somehow FF is not able to do things in other tabs in the background as it should.
Jude is right, autocomplete is not responsible. Once the second tab is loaded,
my text appears in one of its field even if this tab is not active.
Dupe of bug 124750?
(Sorry for the spam; I don't have privs.  Reporter, could you mark this as a dupe please, if it is?  Just use the fields before the additional comments box and submit the form.)
You're right, this is the same bug

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
(In reply to comment #5)
> You're right, this is the same bug
> 
> *** This bug has been marked as a duplicate of 124750 ***

This one is for SeaMonkey, bug 245502 is for Firefox.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.