Closed Bug 252679 Opened 17 years ago Closed 17 years ago

Need EULA for Firefox

Categories

(Firefox :: General, defect, P1)

1.0 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox1.0

People

(Reporter: bugs, Assigned: bugs)

References

Details

(Keywords: fixed-aviary1.0, late-l10n, Whiteboard: [affects l10n] [comment only if you're a lawyer])

Attachments

(1 file, 2 obsolete files)

We need a proper EULA for Firefox for binary distributions, actually we need two
variants, one for our own code, and one for code we distribute through UMO.
Flags: blocking-aviary1.0+
Priority: -- → P1
Target Milestone: --- → Firefox1.0
rafael,  can you track down the pro bono attny and see if we can get something
put together? 
Assignee: bugs → rebron
Blocks: 245198
rafael has draft that might also be good to get into the preview release
Flags: blocking-aviary1.0PR+
Attached file License.txt (obsolete) —
License file.
In part 6 only "it's" is used instead of "its".
granrose, can you see about dropping this into the installers?
Assignee: rebron → granrosebugs
This needs to be cleared by Mitchell still.
sure.  what's the timeframe?
I asked licensing@mozilla.org about this earlier, and the license in
Help->About->Credits... what do we do with localized builds and license files?
Gerv said have English first then translated, but that sounds kinda odd.
Comment on attachment 156302 [details]
License.txt

Not cleared for PR1
Attachment #156302 - Flags: review-
Did Mitchell not clear this for PR1, or what happened? Also... IANAL, just a
concerned onlooker, but doesn't clause 4 take away many rights of the user? A
few choice quotes

>Licensee may not: (i) modify or create any derivative works of the Product or
>documentation, including customization, translation or localization;
This means that I can not take a copy of Firefox, localize it to my native
language, and provide the XPI's? Why not?

>(iii) redistribute, encumber, sell, rent, lease, sublicense, or otherwise
>transfer rights to the Product; 
"redistribute"? So, I am not allowed to burn a CD for my friends?

>(vi) authorize or assist any third party to do any of the things described in
>this paragraph.
So, now I cant localize it, and I can't also get a l10n team together.

Also, what is with the starting quote:
>Redistribution Or Rental Not Permitted
I can't redistribute the software?
guess we will get this for the next release candidate after PR
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR-
Let's get this show on the road: if this file can be localized, or parts of it,
then we need to get this in ASAP (l10n freeze is *tomorrow*). As a sidenote, I
hate this, I and don't understand why we need any license screen at all.
Trademarks are trademarks whether or not the user accepts a license agreement,
and the MPL is a source-level license that does not affect the binaries unless
you start hacking them. I would prefer to remove the license screen from the
installer altogether.
Whiteboard: [affects l10n]
bsmedberg: the installer app should support a license in case someone else
repackages the installer w/ something that needs one.

personally for mozilla.org builds i don't think a license makes any sense.
Wouldn't you need to make clear that mozilla.org is not responsible for any harm
caused by using the product, etc., etc.?
And it might be nice to have an explicit notice allowing redistribution of the
package.
What on _earth_ are you guys smoking. Redistribution is not permitted? Hello?
May not modify the code? May not reverse engineer it? May not customise it? May 
not localise it? May not decompile the product? May not transfer rights to the 
product? May not assist third parties to customise the product???

Are you guys on crack? Seriously?

We *WANT* people to copy the software. We *WANT* people to redistribute it. We 
*WANT* people to be able to customise it, localise it, decompile it, hack it, 
modify it.

The only thing there is to protect here is the artwork and liability. Don't let 
it go to your heads and start restricting our users rights for no reason. It's 
just ridiculous.
I hate the idea of a EULA screen. There is License.txt and that is enough.
Ditto to Hixie's comment.
(In reply to comment #16)
> I hate the idea of a EULA screen. There is License.txt and that is enough.
> Ditto to Hixie's comment.

My god, I just read the attachment (License.txt) - wtf. 

Some things that I was surprised about: "EXPORT CONTROLS", "RESTRICTIONS" and
whats up with this comment "Licensor grants Licensee a non-exclusive and
non-transferable license to install and use for personal or internal business
purposes the executable code version" -- individuals and businesses *should* be
able to hack on the code. 

And btw, I thought that FF was under the MPL
(http://www.mozilla.org/MPL/MPL-1.1.html).

If FF devs decide to go with a license and one that is not the MPL, why not go
with something under http://www.opensource.org/licenses/

Adding another license to the pile isn't the answer.

My 2 cents

- Mick
(Note that while I think the license proposed here is insane, it _is_ legal 
within the framework of the MPL -- the MPL explicitly allows people to create 
restrictive licenses when distributing executable versions of the program, so 
long as they also provide the source code somewhere with no restrictions.)
Did I not say this attachment is invalid and the review is "-"?  A EULA is
needed to protect us from frivolous lawsuits and that's all.  All the other MPL
stuff stands.  This bug is on Mitchell's plate.  

As far as tha attachment, we used the Netscape one as a basis for the EULA which
was incorrect.  We've created a new one that's still being reviewed by Mitchell.  
Does that mean there are countries were you, as a software distributor, have 
certain obligations, which you can legally extract yourselves from by 
requesting that the user click a button when installing the software?
Mitchell said (IIRC) that this isn't necessarily a blocker. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
rafael: I would be curious to hear the reply to my questin in comment 19.
Attached file License for SML (obsolete) —
This might be helpful. The entire text of this license agreement would fit on a

single dialog page, and it's written in much simpler English than most
legalese.
I'm of the opinion that the installer should have an informative license page
with text similar to this, referring of course to the text of the MPL (or GPL
or whatever) for full legal impact. That way we're up front with the legal
requirements: we're not hiding any of it as hard-to-find print. Also, the
message is not hostile, it's short and to the point (so it's likely to get read
by the slightly-less-impatient), and it introduces the user to the freedoms
they
get with Firefox being Free software, such as the freedom to redistribute,
which
we want.
Ian,

There are pro-bono attorneys looking at the EULA and it will also be localized
to work with other countries (translated, legally correct per locale).  That's
the hope at least.
rafael: Sorry, my bad. I meant the question in comment 20.

fantasai: Except for disclaimers (which we might need, I don't know, hence my
question in comment 20 above), there is no need for an EULA for the MPL parts.
The MPL doesn't restrict the user's rights, it only extends them, so we don't
need them to agree to the terms.
is blocking for final...

mitchell is working on pullng the right stuff together.
Flags: blocking-aviary1.0- → blocking-aviary1.0+
Keywords: late-l10n
Why does Firefox need one of these, is "EULA" not an oxymoron and is there
anywhere were any jurisdiction where these have any legal weight?
(In reply to comment #27)
> Why does Firefox need one of these, is "EULA" not an oxymoron and is there
> anywhere were any jurisdiction where these have any legal weight?

Does it really matter? Microsoft doesn't seem to care. If the implied legality
of a EULA dissuades someone from filing a lawsuit, then the EULA has done its
job. <grin>
Version: unspecified → 1.0 Branch
If the idea is just to deny culpability, what's wrong with one of the standard
MPL boilerplates available from http://www.mozilla.org/MPL/boilerplate-1.1/ ?  
Re: #28:
>>Does it really matter?<<

If you are attempting to support this controversial and legally questionable
proposal then it seems to me that this is an argument (to the extent it is one)
for keeping the status quo and not introducing this "EULA".


>>Microsoft doesn't seem to care.<<

Care about what? Microsoft has nothing to do with Firefox.  Why would they care
much about anything to do with it?  They have a totally different proprietary
business model.


>>dissuades someone from filing a lawsuit<<

What sort of lawsuit by whom against whom?  If you are talking about lawsuits
against the Mozilla Foundation, what are they currently doing that is illegal
and why don't they stop doing?


>>then the EULA has done its job.<<

I am asking what that "job" is*.  I genuinely think it would be helpful if
someone explained here what is trying to be achieved by this RFE (and also the
morality and legality of such a proposal).  You have not done so.  (Please send
commments/flames on specifics of my post to me directly unless they shed light
on the raison d'etre of this bug.) 

[* NB: if "its job" = restricting the use of Fx and thereby making the official
builds proprietary (as it seems from the license.txt attachment), then I think a
lot of users and developers will definitely have something to say about it.]
I think an EULA is un-suitable for firefox. 
If firefox gets an eula then it will loose it's status of an 'open source'
browser becuase it is being distributed under an EULA not a public liscense. I
will not update if this EULA is implemented.
Oh and by the way section 4 seems to self destroy as I'm party to MPL and that
says I can do what I want. 
I also hate this.  It'll impede development, among other things already mentioned.
This is idiotic. If Firefox goes this route, expect someone to take Firefox and
fork it like X.org forked XFree. The infighting would probably scare off casual
adaptors, hurting adoption of both branches.
(In reply to comment #30)
> Re: #28:
> >>Does it really matter?<<
> 
> If you are attempting to support this controversial and legally questionable
> proposal then it seems to me that this is an argument (to the extent it is 
> one) for keeping the status quo and not introducing this "EULA".

I don't think an EULA is really necessary, but extra protection never hurts.

> >>Microsoft doesn't seem to care.<<
> 
> Care about what? Microsoft has nothing to do with Firefox.  Why would they 
> care much about anything to do with it?  They have a totally different 
> proprietary business model.

The point was Micorsoft doesn't really care about the legality of an EULA when
they add them to their products.

There haven't been any huge court cases declaring EULAs invalid. And until there
are EULAs will be accepted as legally binding. Controversy notwithstanding.

> >>dissuades someone from filing a lawsuit<<
> 
> What sort of lawsuit by whom against whom?  If you are talking about lawsuits
> against the Mozilla Foundation, what are they currently doing that is illegal
> and why don't they stop doing?

Are you totally missing one of the points of EULAs?

Let's say a company has a customer database they maintain. The database is on
(X) software (Filemaker, an Oracle solution, ect), employees access information
on the database using (Y) software (where Y could potentially be a web browser).
Customer database is flubbed because of database software bug (or maybe database
server falls on its face after having an internation with (Y) access program it
may not normally deal with). The Company loses lots of money in sales, support,
IT costs cleaning up the mess. They want to sue. Oops. The EULA in the (X)
database software or (Y) access software says the vendor of said software is not
responsible for all coincidental, horrible, unavoidable damages, ect.

While Firefox is in it's current version state we have that stern warning, this
is *Pre-release*, do not use for anything mision-critical, at-your-own-risk and
so on. But once Firefox reaches version 1.0, it will not be "pre-release"
anymore. Unless stated otherwise, like in a formal EULA, certian implied
warranties may be taken by users/corporations.

> >>then the EULA has done its job.<<
> 
> I am asking what that "job" is*.

It's job is to make people think twice about filing a frivolous lawsuits against
the Mozilla Foundation (as previous comments have pointed out). The EULA is not
there to make Firefox a proprietary program. It's to strengthen the position of
the makers in relation to use of the product. In court, it really doesn't matter
who is right, it's whoever can keep their lawyers on retainer the longest who
wins. The Mozilla foundation doesn't maintain a huge legal fund to fight an
artifically lengthened damages trail, last I heard.
Comment on attachment 156302 [details]
License.txt

/. has a psuedo-link here, and minus'ing is not enough.  This attachment should
be marked obsolete (it never should have been attached at all).

/be
Attachment #156302 - Attachment is obsolete: true
This is a very bad idea. EULA's are synonymous with control and supression.
Firefox needs no EULA. This is a horrible idea, and I am shocked as to why there
isn't a large outcry to this like the outcries to the (suggested) removal of
View Source and the temoporary remove of AltSS.

Doesn't the MPL disclaim liability enough?

If I see an EULA in Firefox 1.0, I won't install it. I'll just stick to the last
non-EULA nightly.
Maybe we should just call it a "disclaimer of liability", since that's its
actual purpose and "EULA" is such a hot-button word.
#16,#31,#32,#36 (and others)

Instead of outrageous hostility at the very idea of a license, why don't you
wait and see what the Foundation come up with. Read the eventual license, and
*then* criticise it.

#30 - As was stated before, the foundation has lawyers working on this, so I
don't know where you get 'legally questionable' from.
(In reply to comment #38)
> #16,#31,#32,#36 (and others)
> 
> Instead of outrageous hostility at the very idea of a license, why don't you
> wait and see what the Foundation come up with. Read the eventual license, and
> *then* criticise it.
> 
> #30 - As was stated before, the foundation has lawyers working on this, so I
> don't know where you get 'legally questionable' from.

Yes. You do have a point. I apologize.

(In reply to comment #37)
>Maybe we should just call it a "disclaimer of liability", since that's its
>actual purpose and "EULA" is such a hot-button word.

Yeah. EULA is a bad term for it. But I'm not utterly sure "disclaimer of
liabilty" sounds too hot eiter, especially to an end user.

Is this eventual document going to be within the installer, or in a text file in
the firefox directory?

Some users could be weary of clicking "next" on a screen with the title of
"disclaimer of liability."
Regarding the possible name of the license how about "Documentation License"
(In reply to comment #40)
> Regarding the possible name of the license how about "Documentation License"

oops I meant "free software license"
If you want the EULA (hopefully not such a piece of AOLish cr*p like attachment
156302 [details]) translated and legally OK, it must be ready some days before the release.

So it won't be possible to insert such an EULA to 1.0 RC 1 if you want to
release it this week. The l10n people aren't usually able to translate legal
papers themselves (for example, in Poland such a translation would not have any
power, it must be translated by a state-licensed legal translator). 

Also what is the reasoning for an EULA at all? Just put MPL + information about
trademarks + some legal stuff about the update.mozilla.org extensions. That's all.
I don't think we need an EULA, we don't need a license at all in the installer -
all it does is make the install process one step longer on Windows and Linux,
also as noted previously it affects localization and at this late stage do you
want translators worrying about translating legal documents or would you rather
have them finishing translating the UI?

The browser acknowledges the trademark rights in the about box, I think all
that's needed is something on the download page that says something like
"Mozilla and Firefox are trademarks of the Mozilla Foundation, you are free to
redistribute the product as-is, however if you wish to make modifications please
consult our trademark policy if you wish to use our trademarks to identify your
product"

This text could also be repeated somewhere on the page that is first run when
you use Firefox.

I'm all for making the install process as simple as possible, I noticed a post
on the IE blog that claimed that it's currently easier to install Firefox, then
to set Google as default search engine in IE using their official method, lets
make it even easier: http://blogs.msdn.com/ie/archive/2004/10/08/240062.aspx#242260
Mozilla should stay away from demanding licence agreement during the
installation process because at that time a user has already decided that he
wants the software on his system and most users just click EULA's away, i.e.
accept it without taking the trouble of even trying to understand the legal
consequences.

Any user, be it private or a company, that considers the applicability of the
Mozilla software will also need to take into account the legal consequences; and
when he does consider those possible consequences, than he will need the proper
information readily and easily available, and that is surely not from the
installer. The installer may still include a simple message with a usage warning
(disclaimer), trademark notices and a reference on where to find all information
related to licencing and other legal issues of interest. It would just be a
notice and the user would not be required to agree.

BTW, in general any legal conditions may have very different applicability
depending on the country of user. Also for this reason having a reference to
relevant information, rather than trying to incorparate it in the distribution
of a product or its installer, seems more sensible.
You all seem to be quite happy agreeing to the MPL whenever you install
Firefox/Thunderbird/Mozilla...

So why is a different license for binaries (probably including the trademark
stuff) any different?

#44 - you claim that the installer is a bad place for the license, but then want
people to use the installer to find out where to get the license??

I challenge you to find a high-profile program without a license in the installer.
(In reply to comment #45)
> You all seem to be quite happy agreeing to the MPL whenever you install
> Firefox/Thunderbird/Mozilla...
>
> So why is a different license for binaries (probably including the trademark
> stuff) any different?

Because it is not the MPL that we know and trust.
Folks, we have enough opinions, so unless you can provide some legal expertise for
a particular market, there's no need to comment.
Like, Mitchell is well aware of the limited legal relevance of click-away EULAs
in some markets (like germany, according to an article by a lawyer in a recent
c't article).
Last I heard about it, the scheme was like nothing I read in this bug. So unless
we see a scheme, there is no use in reiterating the "make sure that you don't do
worse".
Whiteboard: [affects l10n] → [affects l10n] [comment only if you're a lawyer]
>#16,#31,#32,#36 (and others)

>Instead of outrageous hostility at the very idea of a license, why don't you
>wait and see what the Foundation come up with. Read the eventual license, and
>*then* criticise it.

>#30 - As was stated before, the foundation has lawyers working on this, so I
>don't know where you get 'legally questionable' from.

Sorry Doug,
But tell me this how will this help firefox in ANY way? You tell me and I'll
agree, IT's just too trivial a thing to be blocking anything in my opinion and
most users ignore it. 
IANAL, but Mitchell Baker who is working on this (per comment #26), 'was the
attorney at Netscape responsible for all legal issues related to product
development and intellectual property protection. During that time she wrote the
Netscape and Mozilla Public Licenses.' [mozilla.org staff page]

I would assume she's fairly competent, and is doing this for a reason...
Regarding comment #37 and followups, I would also like to avoid the word
"license" in the installer screen.  I agree with comment #39 that "disclaimer of
liability" does not sound too good either.  But then what about using only
"Disclaimer" as the title?

If the installer screen contains a single paragraph with the title "disclaimer"
and only a few simple words saying that there is no warranty and mozilla.org is
not liable for damages, then I expect that very few people would object.
Anything that looks like an EULA is likely to draw some criticism from people
who are anti-EULA (whether this criticism is justified or not is not something
to be debated here).

From my point of view (IANAL), the best solution would be a very simple
disclaimer screen explaining that there is no warranty, without any other legal
terms.  It would provide a link to the full Mozilla license for those who want
to read it.
Firefox is licensed under MPL, GPL and LGPL. ANY of those three licenses DOES
NOT cover usage in any way, so End User License Agreement for them simply does
not make sense, and EULA that is more restricted than them even less so, because
it would actually be a lie.

IMHO this should be either a WONTFIX or a simple disclaimer with possible link
for those who are interested in redistributing or creating derivative works
(which is the only thing those licenses cover)
Juha: Your statement is not correct. Mozilla code is licensed under the MPL,
LGPL, *or* MPL. The MPL is specifically a source-level license and
redistributors may release binaries under whatever license they choose. But
without an license attachment approved by mitchell, this whole discussion is moot.
Flags: blocking-aviary1.0mac+
We're looking to go gold on Tuesday November 2, but it's possible this could
sneak in after that. 
Attached patch patchSplinter Review
new license text from attorneys, worked into the installer build system
Attachment #160240 - Attachment is obsolete: true
Assignee: granrosebugs → bugs
Status: NEW → ASSIGNED
landed. 
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Comment on attachment 164814 [details] [diff] [review]
patch

> A SOURCE CODE VERSION OF CERTAIN FIREFOX BROWSER FUNCTIONALITY THAT 
> YOU MAY USE, MODIFY AND DISTRIBUTE IS AVAILABLE TO YOU 
> FREE-OF-CHARGE FROM WWW.MOZILLA.ORG UNDER THE MOZILLA PUBLIC 
> LICENSE and other open source software licenses. 
>
> The accompanying executable code version of Mozilla Firefox and 
> related documentation (the "Product") is made available to you 
> under the terms of this MOZILLA FIREFOX END-USER SOFTWARE LICENSE 
> AGREEMENT (THE “AGREEMENT”).  BY CLICKING THE "ACCEPT" BUTTON, OR 
> BY INSTALLING OR USING THE MOZILLA FIREFOX BROWSER, YOU ARE 
> CONSENTING TO BE BOUND BY THE AGREEMENT.  IF YOU DO NOT AGREE TO 
> THE TERMS AND CONDITIONS OF THIS AGREEMENT, DO NOT CLICK THE 
> "ACCEPT" BUTTON, AND DO NOT INSTALL OR USE ANY PART OF THE MOZILLA 
> FIREFOX BROWSER.

Why are two halves of sentences here in lowercase and the rest in upper case?
This isn't a disclaimer. Heck the first paragraph doesn't even license
anything, it's just an informative note.


Looking at the actual license, we have:

1. LICENSE GRANT: Header information that places the rest of the license in a
legal framework.
2.  TERMINATION: The closure part of the framework.
3.  PROPRIETARY RIGHTS: First part says that this license doesn't restrict the
user's rights for most of the product. The second part states a legal fact,
namely that the trademarks and other parts of the product _not_ covered by the
open source licenses are not licensed. In summary, part 3 doesn't actually do
anything.
4.  DISCLAIMER OF WARRANTY: disclaimers. (see note below)
5.  LIMITATION OF LIABILITY: disclaimers. (see note below)
6.  EXPORT CONTROLS: States a legal fact regarding exports.
7.  U.S. GOVERNMENT END-USERS: Not a license, just something that we could have
in the about box.
8.  MISCELLANEOUS: More legal framework.

So in conclusion, the only actual content in the license is a set of
disclaimers.

So here is my question:

   Are there countries where Mozilla Foundation, as a software 
   distributor, has certain obligations, which it can legally extract
   itself from through the use of this license?
Unfortunately that uppercasing mania comes from a US law that states that
certain parts of contracts/licenses have to be uppercase and bigger than 10 pt.

Can we get rid of as much text as anyhow possible? This really is too long.
I'm not talking about the uppercasing in the later sections. I'm talking about
the mixed case sentences at the start, which don't even form part of the license
 terms itself.
Still part of the license document - I just looked at a couple of others (on
american software) and the mixed case in the preamble seems to be usual.

As for your question, IANAL, but from reading previous discussions, I understand
that disclaimers like this can help one's defence in the US (at least in some
states) if someone sues you because what you gave them caused them problems. The
license may be stating the obvious, but failure to state the obvious can
apparently lead to arguments that you didn't mean it because you didn't state
it. I understand that this kind of thing is pretty much useless in the UK, but
it might possibly help in some obscure circumstance and it doesn't do any harm,
legally, to put it there, so lawyers go for having it anyway.

I don't think there's much point in disputing it anyway, unless the foundation's
lawyers are going to read this. It may be redundant, but there's nothing evil in it.
Keywords: fixed-aviary1.0
It does harm because EULAs are of dubious legal standing in the first place, and
if the first thing a user sees when installing his first piece of free software
is a legal agreement, he's going to miss one of the biggest points of free
software (namely, the freedom from this kind of crap).
WWW.MOZILLA.ORG/LICENSING

that's 404. lowercase licensing works, but the license explicitly uses
uppercase. this should be fixed. I also think it should use an http:// prefix.
>6.  EXPORT CONTROLS.  This license is subject to all applicable export
restrictions.  You must comply with all export and import laws and restrictions
and regulations of any United States or foreign agency or authority relating to
the Product and its use.  

why does this need to be there? I do not think that mozilla foundation needs to
enforce US law. I mean, what this is saying is, if people export firefox to some
country that the US govt doesn't like, they must not use firefox. does US law
require this statement?
"I mean, what this is saying is, if people export firefox to some country that
the US govt doesn't like, they must not use firefox. does US law require this
statement?"

Not explicitly, AIUI (IANAL, but I do work for a US-registered organisation),
but US law does require that the (encryption) code isn't exported to places the
US government doesn't like, and it is the person in the US that's responsible
for complying with that. It would be illegal, for example, for the Foundation to
supply the code to you in Europe, if they knew that it was your intention to
send it on to someone in Iran.

In other words, I don't think they're actually required to enforce the law, but
they are required not to be complicit in breaking the law. I guess if they tell
you not to re-export it and you do it anyway without their knowledge, they have
some kind of defense.

The capitalisation point is a good one (assuming that anyone is actually going
to read the license :), but that could also be fixed by setting up a redirect on
the server from the uppercase version to the lowercase.
>In other words, I don't think they're actually required to enforce the law, but
>they are required not to be complicit in breaking the law

but does that mean they are required to remove your right to use firefox if you
do that? ("If you breach this Agreement your right to use the Product will
terminate immediately")
I don't know (I'm not a lawyer, as I said), but in general, if you stand by and
let someone else break the law (in this case, by exporting the software),
without trying to stop them or report them or something, then you assume some of
the guilt.
2. TERMINATION.  If you breach this Agreement your right to use the Product will
terminate immediately and without notice[...]

Why is that clause needed anyway? If you breach the license you're guilty of
copyright infringement and/or violation of contract law. It doesn't help anyone
if you stop using the product as such. Being free software it's quite difficult
to *use* it in an "illegal" way. Distribution is a whole different story.
(In reply to comment #65)
> I don't know (I'm not a lawyer, as I said), but in general, if you stand by and
> let someone else break the law

bah. I'm living in europe, I don't care about US law.
I'm seeing bad line breaks (unix vs windows?) on today's Window's build in the
installer.
If the only reason to do this is an attempt to enhance fxs chance of survival in
the brokal legal world of the U.S., then couldn't there be two versions?

One for the U.S. that comes bundled with EULAS and another one for the rest of
the world that would is able to use a free product without trying to kill the
those who gave it to them.

I'm living in Sweden and I will follow Swedish law. I will not, however, sign an
agreement that entitles the U.S. to decide what I may or may not export to Iraq.
(In reply to comment #69)
> If the only reason to do this is an attempt to enhance fxs chance of survival in
> the brokal legal world of the U.S., then couldn't there be two versions?
> 
> One for the U.S. that comes bundled with EULAS and another one for the rest of
> the world that would is able to use a free product without trying to kill the
> those who gave it to them.
> 
> I'm living in Sweden and I will follow Swedish law. I will not, however, sign an
> agreement that entitles the U.S. to decide what I may or may not export to Iraq.

I don'tt think you properly understand.  Let me first disclaim that I am not a
lawyer, and what I am about to say should not, and in my opinion does not,
constitute legal advice.

Now, I understand you're living in Sweden.  I understand that you follow Swedish
law.  Now, could you please understand that Mozilla "lives" in the US?  And that
Mozilla follows US law?  I'm sure you understand this, which is great - we're
all on the same page.

If Mozilla gives you something, and you give it to Iraq... who's responsible? 
You might say you are, right?  Totally wrong.  You followed your Swedish law
perfectly!  Congratulations!

But... Mozilla is going to get sued to the dust.  They are responsible for
breaking the law, because they let you break US law.  You're not responsible,
yes, because you're not in the US - but Mozilla *is*.

A second version for people outside the US would not work.  If a second version
was made, for people outside the US, that one would be the one that would have
to have MORE legal disclaimers... it would really only mean that the US one
could have (perhaps) less!

Mozilla doesn't want the government to get mad at them.  I don't either.  I
understand that you don't live in the US, and that you probably (like many
people in Europe, but not all) don't think that US politics make sense.  I will
also agree that often they don't.

But, in this case... Mozilla can't say "it's stupid so we won't do it". 
Because, if they do say that, they're asking to get sued or be accused of being
traitors.... not you, no, just them.

Sorry if you don't care about Mozilla, but I do.  I hate EULAs as much as
everyone, but I'm very glad this is fixed.  Another great stride forward for the
Mozilla project.

But, again, I'm not a lawyer.  Sorry for the bugspam, those of you who wish
Mozilla and Firefox to succeed and care about the reality of the legal system. 
And sorry for responding to this topic, not being a lawyer.  I'm really just
explaining what earlier comments have said anyway.

-[Unknown]
Sorry if I appear dumb: bottom line will Firefox be Open Source or not? Will 
we have access to the source code of the whole project?  
Will I be able to contunue to define it an open source project? 
 
I've not understand well all these things. 
 
Kind regards 
@unknown@simplemachines.org: Other free software projects have their export
regulated software on Dutch or Swiss servers or special US and NON-US servers
(debian does this and their server for security relevant things is in the
Netherlands). This solves many problems with overbroad US and French legislation
on encryption technology.
To comment #71 - as always with open source, it depends on your definition. 
Some would say (look at this bug!) that adding a EULA means no.... but
considering the fact that you can still get the source, without ever agreeing to
the EULA - and in fact, you can get the zip and use it without the installer...
I would say it's still as open source as can be.

And, to comment #72 - again, I am not a lawyer.  But, I would think that, as an
example, if John Doe security programmer exported his work to a Swiss server,
which then gets exported through some chain of redistributions to Iraq... well,
that John Doe would still be in trouble.  Or the organization he works for (in
this case Mozilla.)

But, maybe that does solve it.  Maybe it would solve it in this case, even.  But
I do know that it would make my downloads slower (I live in Los Angeles, and I'm
just as impatient as everyone else in this area) so I'd rather take the EULA
anyway :P.

Here I am again with the bugspam.  I'll stop for good now, because anything more
than this is really just speculation on my part.  Let me take this chance again
to note that I am not a lawyer, nor do I have any wish or intent on giving
anyone legal advice of any kind (again, I live in sue-happy LA.)

-[Unknown]
(In reply to comment #71)
> Sorry if I appear dumb: bottom line will Firefox be Open Source or not? Will 
> we have access to the source code of the whole project?  
> Will I be able to contunue to define it an open source project?

The EULA affects your rights (if at all?) with respect to the binary
distribution only. The source tree continues to be tri-licensed as before, and
is unaffected by the EULA. Mozilla/Firefox are most certainly still open source
projects.

Bottom line, to answer your questions: Yes, yes, and yes.
(In reply to comment #72)
> Other free software projects have their export regulated software on Dutch or 
> Swiss servers or special US and NON-US servers (debian does this and their 
> server for security relevant things is in the Netherlands). This solves many 
> problems with overbroad US and French legislation on encryption technology.

All the code hosted on those servers was written outside the US. Unless you're
planning on rewriting the whole of Mozilla outside the US, this doesn't help us
in the slightest. (Note that Linux and many other software projects are based
primarily outside the US anyway.)

Also, those servers are used for encryption code, which used to be covered by a
totally different set of laws in the US (munitions exports). That's a different
problem from whether it is allowed to export to Iraq and other countries.
You need to log in before you can comment on or make changes to this bug.