Firefox recursively opens windows when selected as application to open PDFs

RESOLVED DUPLICATE of bug 218257

Status

()

Firefox
File Handling
--
critical
RESOLVED DUPLICATE of bug 218257
14 years ago
14 years ago

People

(Reporter: phoenix, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

If I select a PDF link to open, Firefox will ask what application to use to open
the PDF. If I then select Firefox as the appropriate application, Firefox
attempts to recursively open windows (one opens the next, which opens the next,
which opens the next, etc) until I kill the application through the process manager.

Reproducible: Always
Steps to Reproduce:
1. Select PDF link to open
2. Select Firefox as the application to open PDF
3.

Actual Results:  
Unlimited windows were opened.

Expected Results:  
Firefox should disallow itself as a valid choice for unknown file types.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 218257 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.