If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash at startup in necko.dll

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: mbirth, Assigned: gordon)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] no estimate)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla M13 (downloaded 01-27-2000) crashes under my Win98 (first edition) when 
trying to launch it. I got it up after the 3rd crash - but after then it crashed 
again and again after showing:

*** Deferring registration of sample JS components
*** Registering sample JS components
nNCL: registering deferred (0)
nNCL: registering deferred (0)

And the Windoze error message is as follows:
MOZILLA caused an invalid page fault in
module NECKO.DLL at 015f:60546877.
Registers:
EAX=00000000 CS=015f EIP=60546877 EFLGS=00010202
EBX=00000001 SS=0167 ESP=0063f948 EBP=0063f9b0
ECX=0084e940 DS=0167 ESI=0084e940 FS=4527
EDX=8166951c ES=0167 EDI=8007000e GS=0000
Bytes at CS:EIP:
8b 08 ff 51 18 8b f8 8b 46 28 50 8b 08 ff 51 10 
Stack dump:
00000000 8007000e 0084e940 60546187 0084e940 00000001 8007000e 0084e940 00765010 
60545fa9 0084e940 6054623e 00000001 80000000 0063fa14 60c2d32a 


I configured the proxy while the one and only run but I deleted the 
mozregistry.dat so it shouldn't find the profile with the configuration.
Under Windows NT4.0 it worked fine with Proxy-settings and all those other 
stuff. No startup-crash there!

Updated

18 years ago
Severity: major → critical

Comment 1

18 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash

Updated

18 years ago
Keywords: beta1
Target Milestone: M14

Comment 2

18 years ago
PDT+
Whiteboard: [PDT+]

Comment 3

18 years ago
Created attachment 4775 [details]
worksforme now

Comment 4

18 years ago
gordon: is this a dup of your bug? 
Assignee: gagan → gordon

Comment 5

18 years ago
this doesn't sound like a dupe of 23709 because all of those are on win95 with a 
 (probably) winsock related crash.  This is on win98. I haven't heard anyone 
else having the necko.dll crash on win98.  

Comment 6

18 years ago
bug seems to affect m13 -> build of feb - 05 - 2000
all *non installer* versions will crash and burn with the error codes previously displayed
the POST m13 installer versions will die after creating the directory and the plugins sub dir
the m13 installer though... it will install successfully - which will then allow all versions of mozilla m13 -> build of feb - 05 - 2000 to work just fine
but there is a side effect to doing this
installing M13 causes paintshop pro6 and zone alarm (www.zonelabs.com) to cease to function - they now become the ones that crash-and-burn, in zone alarm's case, it also causes windows itself to have explorer errors
fixing them causes mozilla to revert to it's DOA condition
I have eliminated mfc42.dll and msvcrt.dll from the list of suspected altered-files - it also is not related to winsock

after I have fixed PSP/etc this is what m13 will display in console bfore dying

nNCL: registering deferred (0)

that one line only
Component: Networking → Browser-General
(Assignee)

Comment 7

18 years ago
I agree, this doesn't look like 23709.  Is there a stack trace, or a Full Circle 
incident report?

Comment 8

18 years ago
Windows error details dump when trying to load/run feb-05-2000 version:

MOZILLA caused an invalid page fault in
module NECKO.DLL at 015f:6055896f.
Registers:
EAX=00000000 CS=015f EIP=6055896f EFLGS=00010202
EBX=00000001 SS=0167 ESP=0068f90c EBP=0068f974
ECX=008a5060 DS=0167 ESI=008a5060 FS=6477
EDX=815d9c84 ES=0167 EDI=8007000e GS=647e
Bytes at CS:EIP:
8b 08 ff 51 18 8b f8 8b 46 28 50 8b 08 ff 51 10 
Stack dump:
00000000 8007000e 008a5060 60558348 008a5060 00000001 8007000e 008a5060 007b4d50 6055816a 008a5060 605583ff 00000001 80000000 0068f9d8 60c4f67b 

as for a full circle report - I don't think mozilla is getting far enough to be able to provide one of those - but as I don't have the full circle version I can't confirm that - I will try that within the day though
(Reporter)

Comment 9

18 years ago
If somebody can tell me how to manually obtain a full circle report, I could do 
it. But Mozilla does not call talkback.exe .....

Comment 10

18 years ago
This bug was originally assigned the networking component.  Now it is in browser 
general.  I would think a necko.dll crash would stay networking component.  
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 2/11/2000

Comment 11

18 years ago
I have Win98 SE and am experiencing this Necko.dll problem. I can reproduce it 
using the FullCircle version (as well as the regular version), but I am quite 
sure that FullCircle is not alive by the point this crash happens. Here is 
what's disturbing: after initially experiencing this crash, I downloaded the 
M13 installer. During install I received an error with Necko.dll. I'm not sure 
exactly what that implies.
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] 2/11/2000 → [PDT+] no estimate
(Assignee)

Comment 12

18 years ago
We tried to reproduce this with the M13 build, the build from 2/10/2000, and the 
tip, but we haven't seen any problem.  We have Win98 SE 4.10.2222 A.  Is anyone 
still experiencing this crash?  Is it with local builds or installer builds?  
Were there problems during installation?  Does it happen even if the 
mozregistry.dat and component files are deleted?
Component: Browser-General → Networking
(Reporter)

Comment 13

18 years ago
I have Win 98 4.10.1998. A friend's Mozilla (M13) also doesn't run after he had 
installed some programs (but he doesn't know which causes the problem). We're 
both using the non-installer FullCircle-version (but FullCircle isn't active at 
the moment of the crash). And deleting mozregistry.dat and those files does not 
help.

Comment 14

18 years ago
We cannot reproduce this bug in house.  Marking WorksForMe.  Please go get 
latest daily build at: ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 15

18 years ago
Worksforme too
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.