No Proxy for: address exclusion problem without full qualified DNS name

RESOLVED DUPLICATE of bug 136789

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 136789
14 years ago
11 years ago

People

(Reporter: Helmut Fischer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When excluding a whole subnet from proxy routing like "localhost,200.0.0.0/18",
a link like http://hostname will nevertheless be forwarded to the proxy.
(hostname in subnet assumed).  It only bypasses the proxy, when entering the
full qualified domain name "http://hostname.intranet.domain.com". 
An(insufficient) workaround is, to exclude "localhost,200.0.0.0/18,hostname"

Reproducible: Always
Steps to Reproduce:
1."No Proxy for" = "localhost, 192.168.100.0/24"
2. http://webserver    (webserver=192.168.100.10)
3. 

Actual Results:  

webserver no found, as routed through proxy


Expected Results:  

to find webserver without using proxy
*** Bug 252816 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
dupe of bug 136789

*** This bug has been marked as a duplicate of 136789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
v/dupe.
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
REOPEN to depends.
This type of feature might not be fixd in both products, so for now, let it
depend on the core problem.
Status: VERIFIED → UNCONFIRMED
Depends on: 136789
OS: Windows XP → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
putting *.ac.uk for example works. It's a mistake in the comment in the proxy
dialog. It says .ac.uk is all you have to type but the * is necc.

Comment 6

14 years ago
I'm not sure this has to depend on bug 136789 which is about resolving names to
addresses before checking to disable the proxy.  I'd like to see a simple way to
disable the proxy for all names which are not fully qualified.
How about a simple dot "." to disable all unqualified names?

Comment 7

14 years ago
Christopher: That is a different bug, see bug 91587.
Summary: Proxy address exlusion problem without full qualified DNS name → No Proxy for: address exlusion problem without full qualified DNS name

Updated

13 years ago
Summary: No Proxy for: address exlusion problem without full qualified DNS name → No Proxy for: address exclusion problem without full qualified DNS name

Comment 8

13 years ago
*** Bug 287263 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
Assignee: bross2 → nobody

Updated

11 years ago
Flags: blocking-firefox3?
This is a core issue, if Necko fixes it, we'll get the fix.
Status: NEW → RESOLVED
Last Resolved: 14 years ago11 years ago
No longer depends on: 136789
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 136789
You need to log in before you can comment on or make changes to this bug.