If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

larger max-connections-per-server setting has no affect.

RESOLVED DUPLICATE of bug 252118

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 252118
13 years ago
9 years ago

People

(Reporter: Brian Bray, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

This may be related/similar to bug #246093 but instead of too many simultanious
connections, its not enough.  I altered my
network.http.max-persistent-connections-per-server setting to 5, yet in download
manager, I'm still unable to download more than 2 items (the default setting)
simultaniously from one site.

Interestingly, this does not happen in regular Mozilla (1.7+).  All 5 start up
at the same time.

Reproducible: Always
Steps to Reproduce:
Find a page that has a bunch of files you want to download in download manager,
like .zip's.  

1. Typically what I'll do is pick 5 files or something to download at once. 
I'll CTRL-CLICK on them so they go into new tabs, so I dont loose my place in
the web page waiting for it to respond.

2. I'll have 5 tabs all loading, the first 2 will load and download manager will
pop up.  The last 3 will continue to churn until one of the items in download
manager completes, then the next tab will stop churning and show up in download
manager, and so on until they are all done.

3. This happens on several sites, I'm confidant that its not a server imposed 2
similtanious connections limitation.

Comment 1

13 years ago
network.http.max-persistent-connections-per-proxy seems to be ignored, too. It
looks like the problem is somewhere in the networking code.
fixed in firefox branch nightlies starting sep 2 (and trunk since aug 3)

*** This bug has been marked as a duplicate of 252118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.