Closed Bug 252995 Opened 17 years ago Closed 17 years ago

Only one cursor for all tabs - javascript can catch cursor from the current tab

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 124750

People

(Reporter: sstrasser, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

There is only one cursor for all tabs, so you can loose your cursor while typing
if a tab loading in background uses javascript to set the cursor to a field.

Reproducible: Always
Steps to Reproduce:
1. Load http://www.google.com in tab 1
2. Start loading http://www.google.com in tab 2
3. Switch to Tab 1 and start writing into search field
4. When Tab 2 is fully loaded you loose your cursor.
In this case you have to be fast to achieve this but there are more annoying
cases(e.g. loading a link in background and continue using the current tab)



Expected Results:  
One cursor for each tab or disable javascript for background tabs.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.